summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-11-21 11:59:37 +0100
committerLudovic Courtès <ludo@gnu.org>2018-11-21 17:38:00 +0100
commitc3d8c6ac7e457bbde72ce54cd4caf4b9610e2d99 (patch)
tree0abd88c4af40bbd350cb9d978b7b93f8312398e9 /gnu/packages/emacs.scm
parente1f791276144bc1737ab855226d3e66e58909f14 (diff)
downloadguix-patches-c3d8c6ac7e457bbde72ce54cd4caf4b9610e2d99.tar
guix-patches-c3d8c6ac7e457bbde72ce54cd4caf4b9610e2d99.tar.gz
gnu: emacs-pdf-tools: Use 'git-fetch'.
* gnu/packages/emacs.scm (emacs-pdf-tools)[source]: Switch to GIT-FETCH. [arguments]: In 'emacs-patch-variables' phase, make files writable.
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index ce1add3915..c386b080e7 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1593,15 +1593,15 @@ filters, new key bindings and faces. It can be enabled by
(package
(name "emacs-pdf-tools")
(version "0.80")
+ (home-page "https://github.com/politza/pdf-tools")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/politza/pdf-tools/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "06imydn3a92vr57azpn1zhqc14kxyyslmyi9ldsyphan9b724gb6"))))
+ "1i4647vax5na73basc5dz4lh9kprir00fh8ps4i0l1y3ippnjs2s"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; there are no tests
@@ -1626,6 +1626,8 @@ filters, new key bindings and faces. It can be enabled by
(lambda _ (chdir "../lisp") #t))
(add-after 'enter-lisp-dir 'emacs-patch-variables
(lambda* (#:key outputs #:allow-other-keys)
+ (for-each make-file-writable (find-files "."))
+
;; Set path to epdfinfo program.
(emacs-substitute-variables "pdf-info.el"
("pdf-info-epdfinfo-program"
@@ -1659,7 +1661,6 @@ filters, new key bindings and faces. It can be enabled by
files. The key difference is that pages are not pre-rendered by
e.g. ghostscript and stored in the file-system, but rather created on-demand
and stored in memory.")
- (home-page "https://github.com/politza/pdf-tools")
(license license:gpl3+)))
(define-public emacs-dash