summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2018-12-29 14:39:40 +0100
committerJelle Licht <jlicht@fsfe.org>2019-01-09 22:38:22 +0100
commitabb8dff054a9e27fcb2b1f4d2d08c2fb66917f84 (patch)
tree529b96f59a061c2bb38019d9b9ef49c4d46aa64e /gnu/packages/emacs.scm
parent56c50c71b57b03251474f9ece4d1f2a6359d33f4 (diff)
downloadguix-patches-abb8dff054a9e27fcb2b1f4d2d08c2fb66917f84.tar
guix-patches-abb8dff054a9e27fcb2b1f4d2d08c2fb66917f84.tar.gz
gnu: Add emacs-treepy.
* gnu/packages/emacs.scm (emacs-treepy): New variable.
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 32919d810d..926e118033 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -622,6 +622,28 @@ these arguments. The prototypical use is for the command to call an external
process, passing on the arguments as command line arguments.")
(license license:gpl3+)))
+(define-public emacs-treepy
+ (package
+ (name "emacs-treepy")
+ (version "0.1.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/volrath/treepy.el.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "04zwm6gx9pxfvgfkizx6pvb1ql8pqxjyzqp8flz0432x0gq5nlxk"))))
+ (build-system emacs-build-system)
+ (home-page
+ "https://github.com/volrath/treepy.el")
+ (synopsis "Tree traversal tools")
+ (description
+ "Generic tools for recursive and iterative tree traversal based on
+clojure.walk and clojure.zip respectively.")
+ (license license:gpl3+)))
+
(define-public emacs-ghub
(package
(name "emacs-ghub")