summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2018-05-03 22:15:01 +0530
committerArun Isaac <arunisaac@systemreboot.net>2018-05-03 22:15:01 +0530
commit90ec79fb2933a4d33ab3861d72e1b4382c8d39f2 (patch)
treefc94d61b66a9f027c240e135042e232102b2f3df /gnu/packages/emacs.scm
parentc1b4ad2e6e5bf9202be5fc5ed243a3b048287e8c (diff)
downloadguix-patches-90ec79fb2933a4d33ab3861d72e1b4382c8d39f2.tar
guix-patches-90ec79fb2933a4d33ab3861d72e1b4382c8d39f2.tar.gz
gnu: emacs-deferred: Fix tests.
* gnu/packages/emacs.scm (emacs-deferred)[arguments]: Add set-shell phase. Set #:test-command to "make test".
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 3eec8fbac2..186b87fec6 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -2567,17 +2567,19 @@ framework for Emacs Lisp to be used with @code{ert}.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'set-shell
+ ;; Setting the SHELL environment variable is required for the tests
+ ;; to find sh.
+ (lambda _
+ (setenv "SHELL" (which "sh"))
+ #t))
(add-before 'check 'fix-makefile
(lambda _
(substitute* "Makefile"
(("\\$\\(CASK\\) exec ") ""))
#t)))
#:tests? #t
- ;; FIXME: Normally we'd run the "test" target but for some reason the
- ;; test-deferred target fails when run in the Guix build environment
- ;; with the error: (file-error "Searching for program" "No such file or
- ;; directory" "/bin/sh").
- #:test-command '("make" "test-concurrent" "test-concurrent-compiled")))
+ #:test-command '("make" "test")))
(native-inputs
`(("emacs-ert-expectations" ,emacs-ert-expectations)
("emacs-undercover" ,emacs-undercover)