summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2018-12-29 14:43:23 +0100
committerJelle Licht <jlicht@fsfe.org>2019-01-09 22:40:13 +0100
commit8d59ef68cb03292e8134524a58f07fca98edef1d (patch)
treebb52d76a716da32cd833e04b68709fc7db310f6b /gnu/packages/emacs.scm
parent5b07f06804cc6089226b9fa7a66dafaec03fc263 (diff)
downloadguix-patches-8d59ef68cb03292e8134524a58f07fca98edef1d.tar
guix-patches-8d59ef68cb03292e8134524a58f07fca98edef1d.tar.gz
gnu: emacs-with-editor: Update to 2.8.0.
* gnu/packages/emacs.scm (emacs-with-editor): Update to 2.8.0. [source]: Use 'git-fetch'.
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 8748146131..ab5b66323f 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -428,16 +428,16 @@ configuration files, such as .gitattributes, .gitignore, and .git/config.")
(define-public emacs-with-editor
(package
(name "emacs-with-editor")
- (version "2.7.3")
+ (version "2.8.0")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/magit/with-editor/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/magit/with-editor.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1ln2s0kckzkv50qmr6x1kb2j30cfjii0vs6lpghg7ff4lav8jqgh"))))
+ "1bbzvxnjpxqyvi808isld025b3pcidn4r2xf8hnk9bmzcfdvdr6q"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-dash" ,emacs-dash)))