summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 19:10:35 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:16 +0300
commit6f83725ff09227c3aefb4f842f80b8943b7b159d (patch)
tree87051979c72adab9f946045d029331aa35947582 /gnu/packages/emacs.scm
parent2f9e1378b60448e455108c03296664820c5e4562 (diff)
downloadguix-patches-6f83725ff09227c3aefb4f842f80b8943b7b159d.tar
guix-patches-6f83725ff09227c3aefb4f842f80b8943b7b159d.tar.gz
gnu: Add emacs-faceup.
* gnu/packages/emacs.scm (emacs-faceup): New public variable.
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 843b97d49f..fee0cf6229 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -9729,3 +9729,28 @@ decreasing the default font size in all GUI Emacs frames.")
(description "This package provides an Emacs regexp command with
interactive visual feedback.")
(license license:gpl3+)))
+
+(define-public emacs-faceup
+ (let ((commit "6c92dad56a133e14e7b27831e1bcf9b3a71ff154")
+ (revision "1"))
+ (package
+ (name "emacs-faceup")
+ (version (string-append "0.0.1" "-" revision "."
+ (string-take commit 7)))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Lindydancer/faceup.git")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1yzmy7flrhrh0i10bdszx8idx6r8h6czm4vm4q0z6fp5fw94zwrx"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/Lindydancer/faceup")
+ (synopsis "Markup language for faces and font-lock regression testing")
+ (description "Emacs is capable of highlighting buffers based on
+language-specific @code{font-lock} rules. This package makes it possible to
+perform regression test for packages that provide font-lock rules.")
+ (license license:gpl3+))))