summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-11-05 13:58:04 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2018-11-05 13:58:33 +0100
commit695db2f98a9099aaea9289f3a34c43e8d120d8b5 (patch)
tree8a9d8a30f20260dbd6d274f8499a76082dbd5eeb /gnu/packages/emacs.scm
parentc9f3d38be49ebd5910cb66f295338097173e6b32 (diff)
downloadguix-patches-695db2f98a9099aaea9289f3a34c43e8d120d8b5.tar
guix-patches-695db2f98a9099aaea9289f3a34c43e8d120d8b5.tar.gz
gnu: Add emacs-helm-slime.
* gnu/packages/emacs.scm (emacs-helm-slime): New variable.
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index d5ad38d1ee..3114a2e5c5 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -12433,3 +12433,33 @@ correctly.")
(synopsis "Color ANSI codes in the REPL of SLIME")
(description "Color ANSI codes in the REPL of SLIME")
(license license:gpl2+))))
+
+(define-public emacs-helm-slime
+ (let ((commit "9980925f3e5f6ac5a30369d2a544e82006a79c76"))
+ (package
+ (name "emacs-helm-slime")
+ (version (git-version "0.0.0" "1" commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/emacs-helm/helm-slime")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0xa07gpfkzwn522x9573mq5mfxvbawdgd0m93gqj6w5a14wk8zzh"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-helm" ,emacs-helm)
+ ("emacs-slime" ,emacs-slime)))
+ (home-page "https://github.com/emacs-helm/helm-slime")
+ (synopsis "Helm for SLIME, the Superior Lisp Interaction Mode for Emacs")
+ (description "Helm-SLIME defines a few new commands:
+
+@itemize
+@item helm-slime-complete: Select a symbol from the SLIME completion systems.
+@item helm-slime-list-connections: Yet another slime-list-connections with Helm.
+@item: helm-slime-apropos: Yet another slime-apropos with Helm.
+@item helm-slime-repl-history: Select an input from the SLIME REPL history and insert it.
+@end itemize\n")
+ (license license:gpl3+))))