summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2019-01-11 13:31:47 +0100
committerJelle Licht <jlicht@fsfe.org>2019-01-11 13:32:31 +0100
commit5a26f879c3f2f417f594171d909acc3f8227a99c (patch)
tree9a801bef684a42e11da87c23c2a09a54fb27314b /gnu/packages/emacs.scm
parentf1de676ea82c2bed9a435fce37ade0186296bfc9 (diff)
downloadguix-patches-5a26f879c3f2f417f594171d909acc3f8227a99c.tar
guix-patches-5a26f879c3f2f417f594171d909acc3f8227a99c.tar.gz
Revert "gnu: emacs-ghub: Update to 3.2.0."
This change should be applied once we update our magit package. This reverts commit b96f0e6ff9f8f36d250b5ae94a908272babb35cf.
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm19
1 files changed, 7 insertions, 12 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 3978d9ab6d..885bb7d5d2 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -677,16 +677,16 @@ deliver data to mobile and web apps.")
(define-public emacs-ghub
(package
(name "emacs-ghub")
- (version "3.2.0")
+ (version "2.0.1")
(source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/magit/ghub.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/magit/ghub/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0lp52qygyavddl1lrgsyb6mq7hcf9h89dy2pzya3mb2va49f0vvl"))))
+ "0d0qj5r1bm2aidi61rigrdaycxnyb7y1ivb3h8rpvvapsf8sk7z0"))))
(build-system emacs-build-system)
(arguments
`(#:phases
@@ -694,11 +694,6 @@ deliver data to mobile and web apps.")
(add-before 'install 'make-info
(lambda _
(invoke "make" "info"))))))
- (propagated-inputs
- `(("emacs-dash" ,emacs-dash)
- ("emacs-graphql" ,emacs-graphql)
- ("emacs-let-alist" ,emacs-let-alist)
- ("emacs-treepy" ,emacs-treepy)))
(native-inputs
`(("texinfo" ,texinfo)))
(home-page "https://github.com/magit/ghub")