summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2018-05-02 19:14:37 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2018-05-02 20:17:19 +0300
commit1a73164da62f9cb51658493ec05692b26f6703c2 (patch)
treeb5de40bbe6b2b4f50fae140666f6ef1e1824107b /gnu/packages/emacs.scm
parent37fa904f0b00eae091750e8fdb92d5aec3013256 (diff)
downloadguix-patches-1a73164da62f9cb51658493ec05692b26f6703c2.tar
guix-patches-1a73164da62f9cb51658493ec05692b26f6703c2.tar.gz
gnu: Add emacs-sml-mode.
* gnu/packages/emacs.scm (emacs-sml-mode): New public variable.
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index b294a1bd34..3f7fcb8ae9 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -10127,3 +10127,24 @@ sections for bookmarks, projectil projects, org-agenda and more. ")
@code{company-mode} which supports the normal and the fuzzy completion
modes of SLIME.")
(license license:gpl3+)))
+
+(define-public emacs-sml-mode
+ (package
+ (name "emacs-sml-mode")
+ (version "6.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://elpa.gnu.org/packages/sml-mode-"
+ version ".el"))
+ (sha256
+ (base32
+ "105fcrz5qp95f2n3fdm3awr6z58sbrjihjss6qnrg4lz2ggbc328"))))
+ (build-system emacs-build-system)
+ (home-page "http://elpa.gnu.org/packages/sml-mode.html")
+ (synopsis "Major mode for editing (Standard) ML")
+ (description "SML-MODE is a major Emacs mode for editing Standard ML.
+It provides syntax highlighting and automatic indentation and
+comes with sml-proc which allows interaction with an inferior SML
+interactive loop.")
+ (license license:gpl3+)))