summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-03-12 22:56:09 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-03-13 13:50:54 +0100
commitfe533002636be8f172b154ce7e54c6ffe2a5c7c9 (patch)
tree55ab0bb616eed91c6fc8ce00c7a93cee0c80f6fe /gnu/packages/emacs-xyz.scm
parent71c97c89b09f2c0670d71c7c0f51c25e827c2f07 (diff)
downloadguix-patches-fe533002636be8f172b154ce7e54c6ffe2a5c7c9.tar
guix-patches-fe533002636be8f172b154ce7e54c6ffe2a5c7c9.tar.gz
gnu: Add emacs-elfeed-score.
* gnu/packages/emacs-xyz.scm (emacs-elfeed-score): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index cb0cfcd07f..a696d27e6e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9053,6 +9053,34 @@ duplicated a lot. Org-mode makes the book keeping of tags and feeds
much easier.")
(license license:gpl3+))))
+(define-public emacs-elfeed-score
+ (package
+ (name "emacs-elfeed-score")
+ (version "0.7.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sp1ff/elfeed-score")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07xid0a31ghknbfwj8dxzbqkg4sfayjhlqvp17p2bzlf1mj0zjyd"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-elfeed" ,emacs-elfeed)))
+ (home-page "https://github.com/sp1ff/elfeed-score")
+ (synopsis "Gnus-style scoring for Elfeed")
+ (description
+ "@Elfeed-score is an add-on for Elfeed, an RSS reader for Emacs. It
+brings Gnus-style scoring to your RSS feeds. Elfeed, by default, displays
+feed entries by date. This package allows you to setup rules for assigning
+numeric scores to entries, and sorting entries with higher scores ahead of
+those with lower, regardless of date. The idea is to prioritize content
+important to you.")
+ (license license:gpl3+)))
+
(define-public emacs-el-x
(package
(name "emacs-el-x")