summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2021-03-10 09:12:02 +0000
committerPierre Langlois <pierre.langlois@gmx.com>2021-03-11 09:54:44 +0000
commitfd2751f89f04669227bbd71243bb100e3742a3fd (patch)
treeb015d659ef4fead1562b03351992edb0432fa886 /gnu/packages/emacs-xyz.scm
parent4a8b529ce15ddc69a9dd701e450fc85a0ed65910 (diff)
downloadguix-patches-fd2751f89f04669227bbd71243bb100e3742a3fd.tar
guix-patches-fd2751f89f04669227bbd71243bb100e3742a3fd.tar.gz
gnu: emacs-password-store: 2.1.4-1.918992c [security fix].
Includes a fix to no longer store clear passwords in a temporary file, see commit 7aa17d099577730d2d65332896b74d5865b22abf for details. * gnu/packages/emacs-xyz.scm (emacs-password-store): Update to 2.1.4-1.918992c. [propagated-inputs]: Remove emacs-f, add emacs-auth-source-pass.
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm70
1 files changed, 38 insertions, 32 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b5785505a5..de3ef6d648 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15041,39 +15041,45 @@ close, copy, cut, paste, undo, redo.")
(license license:gpl3+))))
(define-public emacs-password-store
- (package
- (name "emacs-password-store")
- (version "1.7.3")
- (source (origin
- (method url-fetch)
- (uri
- (string-append "https://git.zx2c4.com/password-store/snapshot/"
- "password-store-" version ".tar.xz"))
- (sha256
- (base32
- "1x53k5dn3cdmvy8m4fqdld4hji5n676ksl0ql4armkmsds26av1b"))))
- (build-system emacs-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'extract-el-file
- (lambda _
- (copy-file "contrib/emacs/password-store.el" "password-store.el")
- (delete-file-recursively "contrib")
- (delete-file-recursively "man")
- (delete-file-recursively "src")
- (delete-file-recursively "tests"))))))
- (propagated-inputs
- `(("emacs-f" ,emacs-f)
- ("emacs-s" ,emacs-s)
- ("emacs-with-editor" ,emacs-with-editor)
- ("password-store" ,password-store)))
- (home-page "https://git.zx2c4.com/password-store/tree/contrib/emacs")
- (synopsis "Password store (pass) support for Emacs")
- (description
- "This package provides functions for working with pass (\"the
+ (let ((commit "918992c19231b33b3d4a3288a7288a620e608cb4")
+ (revision "1"))
+ (package
+ (name "emacs-password-store")
+ ;; The emacs package version does not match the password-store version,
+ ;; even though it is part of the same repository. When updating, look
+ ;; at the version declared in password-store.el.
+ (version (git-version "2.1.4" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "git://git.zx2c4.com/password-store")
+ (commit commit)))
+ (sha256
+ (base32
+ "0ni62f4pq96g0i0q66bch1dl9k4zqwhg7xaf746k3gbbqxcdh3vi"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'extract-el-file
+ (lambda _
+ (copy-file "contrib/emacs/password-store.el" "password-store.el")
+ (delete-file-recursively "contrib")
+ (delete-file-recursively "man")
+ (delete-file-recursively "src")
+ (delete-file-recursively "tests"))))))
+ (propagated-inputs
+ `(("emacs-auth-source-pass" ,emacs-auth-source-pass)
+ ("emacs-s" ,emacs-s)
+ ("emacs-with-editor" ,emacs-with-editor)
+ ("password-store" ,password-store)))
+ (home-page "https://git.zx2c4.com/password-store/tree/contrib/emacs")
+ (synopsis "Password store (pass) support for Emacs")
+ (description
+ "This package provides functions for working with pass (\"the
standard Unix password manager\").")
- (license license:gpl2+)))
+ (license license:gpl2+))))
(define-public emacs-auth-source-pass
(let ((commit "847a1f54ed48856b4dfaaa184583ef2c84173edf")