summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-05-29 10:21:26 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-05-31 21:03:09 +0200
commitdafd3265ad3a83141f45132f1d154964d82f9039 (patch)
tree560aa82dffad7ab2455a3c135c916b7e72af9507 /gnu/packages/emacs-xyz.scm
parentf7825ee85a4b2ea4170f8ad5dbee281704b09371 (diff)
downloadguix-patches-dafd3265ad3a83141f45132f1d154964d82f9039.tar
guix-patches-dafd3265ad3a83141f45132f1d154964d82f9039.tar.gz
gnu: Add emacs-evil-paredit.
* gnu/packages/emacs-xyz.scm (emacs-evil-paredit): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index efdc1cdac8..bd05408561 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11035,6 +11035,33 @@ end of a line and increment or decrement it.")
a popup window for previewing candidates.")
(license license:gpl3+))))
+(define-public emacs-evil-paredit
+ (let ((commit "e058fbdcf9dbf7ad6cc77f0172d7517ef233d55f"))
+ (package
+ (name "emacs-evil-paredit")
+ (version "0.0.2") ; says 0.0.2 in evil-paredit.el
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/roman/evil-paredit")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0b08y4spapl4g2292j3l4cr84gjlvm3rpma3gqld4yb1sxd7v78p"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-evil" ,emacs-evil)
+ ("emacs-paredit" ,emacs-paredit)))
+ (home-page "https://github.com/roman/evil-paredit")
+ (synopsis "Evil extension to integrate nicely with Paredit")
+ (description
+ "This package helps you to not screw up your Paredit setup when using
+Evil mode. Whenever you try to use a modifier command like @kbd{d}, @kbd{c},
+@kbd{y} to modify the Paredit buffer, it will stop you to do so in the case
+you break the parity of parenthesis.")
+ (license license:expat))))
+
(define-public emacs-evil-args
(let ((commit "758ad5ae54ad34202064fec192c88151c08cb387")
(revision "1"))