summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-07-26 00:22:24 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-07-26 10:57:22 +0300
commitce1c5492900d7cb1248fb05ee9dc63362add624e (patch)
tree7a63e6fbb35b4ae2d3d2f23e6424f6da4b747d64 /gnu/packages/emacs-xyz.scm
parent74dc65b834cb21ba623046ce800d915375b81fc9 (diff)
downloadguix-patches-ce1c5492900d7cb1248fb05ee9dc63362add624e.tar
guix-patches-ce1c5492900d7cb1248fb05ee9dc63362add624e.tar.gz
gnu: emacs-ansi: Update to 0.4.1-1.a41d5cc.
* gnu/packages/emacs-xyz.scm (emacs-ansi): Update to 0.4.1-1.a41d5cc.
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm42
1 files changed, 22 insertions, 20 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index db395361b9..8948eb0ab9 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11277,29 +11277,31 @@ lines, and @code{gc} to comment out the target of a motion.")
;; Tests for emacs-ansi have a circular dependency with ert-runner, and
;; therefore cannot be run
(define-public emacs-ansi
- (package
- (name "emacs-ansi")
- (version "0.4.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/rejeep/ansi.el")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1hbddxarr40ygvaw4pwaivq2l4f0brszw73w1r50lkjlggb7bl3g"))))
- (build-system emacs-build-system)
- (propagated-inputs
- `(("emacs-dash" ,emacs-dash)
- ("emacs-s" ,emacs-s)))
- (home-page "https://github.com/rejeep/ansi.el")
- (synopsis "Convert strings to ANSI")
- (description "@code{emacs-ansi} defines functions that turns simple
+ (let ((commit "a41d5cc719297515d85bb5256980cd1204a71b88")
+ (revision "1"))
+ (package
+ (name "emacs-ansi")
+ (version (git-version "0.4.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rejeep/ansi.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "051v8dmji90chwbsyqsqry7h35mksal2j6rgw1kpmjsni86d79y1"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-s" ,emacs-s)))
+ (home-page "https://github.com/rejeep/ansi.el")
+ (synopsis "Convert strings to ANSI")
+ (description "@code{emacs-ansi} defines functions that turns simple
strings to ANSI strings. Turning a string into an ANSI string can be to add
color to a text, add color in the background of a text or adding a style, such
as bold, underscore or italic.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
;; Tests for emacs-commander have a circular dependency with ert-runner, and
;; therefore cannot be run