summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2021-04-17 19:06:32 +0200
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-05-01 15:56:40 +0200
commitc409cea2d8b78f747c5c251ebbdfd9f068f8701a (patch)
tree52ee82db11597e642e92e9cd1e16bcc1b7718795 /gnu/packages/emacs-xyz.scm
parentc4fac5dd7f3e52beecd9b3761b490add80a38aa7 (diff)
downloadguix-patches-c409cea2d8b78f747c5c251ebbdfd9f068f8701a.tar
guix-patches-c409cea2d8b78f747c5c251ebbdfd9f068f8701a.tar.gz
gnu: emacs-edbi: Adjust to changes in emacs-build-system.
* gnu/packages/emacs-xyz.scm (emacs-edbi)[patch-path]: Execute after unpack. [wrap-edbi-bridge]: New phase (after wrap). Find edbi-bridge in elpa-directory.
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 14 insertions, 10 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b9212ae0d7..44f85f11b7 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21593,17 +21593,21 @@ asynchronous communications, the RPC response is fairly good.")
`(#:include '("\\.el$" "\\.pl$")
#:phases
(modify-phases %standard-phases
- (add-after 'install 'patch-path
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((perl (assoc-ref inputs "perl"))
- (dir (string-append (assoc-ref outputs "out")
- "/share/emacs/site-lisp")))
- (substitute* (string-append dir "/edbi.el")
+ (add-after 'unpack 'patch-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((perl (assoc-ref inputs "perl")))
+ (substitute* "edbi.el"
(("\"perl\"") (string-append "\"" perl "/bin/perl\"")))
- (chmod (string-append dir "/edbi-bridge.pl") #o555)
- (wrap-program (string-append dir "/edbi-bridge.pl")
- `("PERL5LIB" ":" prefix (,(getenv "PERL5LIB"))))
- #t))))))
+ #t)))
+ (add-after 'wrap 'wrap-edbi-bridge
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bridge (string-append (elpa-directory out)
+ "/edbi-bridge.pl")))
+ (chmod bridge #o555)
+ (wrap-program bridge
+ `("PERL5LIB" ":" prefix (,(getenv "PERL5LIB")))))
+ #t)))))
(synopsis "Database Interface for Emacs Lisp")
(description "This program connects the database server through Perl's
DBI, and provides DB-accessing API and the simple management UI.")