summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorZ572 <873216071@qq.com>2021-05-12 00:16:45 +0800
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-05-11 19:30:31 +0200
commitbb29c2657281dd2bc76c2fdb643bff4f3e4caed4 (patch)
tree2850f4b4b468e35364e44bf76aa314a900674372 /gnu/packages/emacs-xyz.scm
parenta3df382525ac515d1aa083f7f5bd3bd31eb1df40 (diff)
downloadguix-patches-bb29c2657281dd2bc76c2fdb643bff4f3e4caed4.tar
guix-patches-bb29c2657281dd2bc76c2fdb643bff4f3e4caed4.tar.gz
gnu: emacs-rime: Adjust to changes in emacs-build-system.
* gnu/packages/emacs-xyz.scm (emacs-rime):[arguments]: Use #:include rather than #:phases to add librime-emacs.so. Signed-off-by: Leo Prikler <leo.prikler@student.tugraz.at>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index fc4c03965e..ff90c6bd3a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -97,6 +97,7 @@
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2021 Eugene Klimov <lipklim@mailbox.org>
+;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25720,7 +25721,8 @@ REPL appropriate to the current major mode.")
(base32 "1a50cziwg7lpgh26yvwxs46jfyfq1m0l6igbg5g5m288mz4d3an9"))))
(build-system emacs-build-system)
(arguments
- '(#:phases
+ '(#:include (cons "\\.so$" %default-include)
+ #:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-rime-data-path
(lambda* (#:key inputs #:allow-other-keys)
@@ -25732,13 +25734,7 @@ REPL appropriate to the current major mode.")
#t))
(add-before 'install 'build-emacs-module
(lambda _
- (invoke "make" "lib")))
- (add-after 'install 'install-emacs-module
- (lambda* (#:key outputs #:allow-other-keys)
- (install-file "librime-emacs.so"
- (string-append (assoc-ref outputs "out")
- "/share/emacs/site-lisp"))
- #t)))))
+ (invoke "make" "lib"))))))
(inputs
`(("librime" ,librime)
("rime-data" ,rime-data)))