summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorAndré Alexandre Gomes <andremegafone@gmail.com>2020-12-28 17:49:06 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-12-28 17:49:06 +0100
commitbb1efe432edc10a0c251df97eba552031f523812 (patch)
tree24440b7fba28f8b191522b2e4d4dd4adc380ab66 /gnu/packages/emacs-xyz.scm
parent25c3ce9dd8d40374f434b8fe6ec32f16996451f0 (diff)
downloadguix-patches-bb1efe432edc10a0c251df97eba552031f523812.tar
guix-patches-bb1efe432edc10a0c251df97eba552031f523812.tar.gz
gnu: Add emacs-keycast.
* gnu/packages/emacs-xyz.scm (emacs-keycast): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 629b602f4f..accd47ae14 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3008,6 +3008,28 @@ depicting stroke orders for all Kanji. The collection is a slightly modified
and limited version of the images provided by the KanjiVG project.")
(license license:gpl3+))))
+(define-public emacs-keycast
+ (package
+ (name "emacs-keycast")
+ (version "1.0.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tarsius/keycast.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1g9arjdhdpvsw47ny9gi5k758ya37yza4mr0rhbf02yvrqyfsrgr"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/tarsius/keycast")
+ (synopsis "Show current command and its key in the mode line")
+ (description
+ "This package provides Keycast mode. Once enabled, that mode shows the
+current command and its key or mouse binding in the mode line, and updates
+them whenever another command is invoked.")
+ (license license:gpl3+)))
+
(define-public emacs-keyfreq
(package
(name "emacs-keyfreq")