summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorJoseph LaFreniere <joseph@lafreniere.xyz>2020-07-24 21:38:06 -0500
committerOleg Pykhalov <go.wigust@gmail.com>2020-07-25 17:04:50 +0300
commitb8901175b7103da7bfe76a392967d21e3371d50f (patch)
tree4752c968f28cdece4702b0fdc3421c2bf7ebbd3c /gnu/packages/emacs-xyz.scm
parent554fd0e869567b7782843340143451a8cef612dd (diff)
downloadguix-patches-b8901175b7103da7bfe76a392967d21e3371d50f.tar
guix-patches-b8901175b7103da7bfe76a392967d21e3371d50f.tar.gz
gnu: Add emacs-shx.
* gnu/packages/emacs-xyz.scm (emacs-shx): New variable. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 42dd35fd22..db395361b9 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3918,6 +3918,38 @@ the speedbar window.")
"This package provides commands to quickly switch between shell buffers.")
(license license:gpl3+)))
+(define-public emacs-shx
+ (package
+ (name "emacs-shx")
+ (version "1.4.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/riscy/shx-for-emacs")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0p9b621rgy34r1hl9xfzxh4xpx9gpsr3n330ypfxhlr0s5754j73"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; A docstring provides examples of mapping hosts to programs in /bin.
+ ;; These examples are valid as-is.
+ (delete 'patch-el-files))
+ #:tests? #t
+ #:test-command
+ '("emacs" "--batch" "--quiet"
+ "--script" "test/script.el")))
+ (home-page "https://github.com/riscy/shx-for-emacs")
+ (synopsis "Extras for the comint-mode shell")
+ (description
+ "This package extends @code{comint-mode}: it parses markup in the output
+stream, enabling plots and graphics to be embedded, and adds command-line
+functions which plug into Emacs (e.g. use @code{:e <filename>} to edit a
+file).")
+ (license license:gpl3+)))
+
(define-public emacs-names
(let ((commit "d8baba5360e5253938a25d3e005455b6d2d86971")
(version "20151201.0")