summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-05-19 20:33:22 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-05-19 20:38:09 +0200
commita0461f9fbd7e641f520eb543e967e59afdae31ea (patch)
tree492c98875ea6e486721c26e4b181de641ba109fc /gnu/packages/emacs-xyz.scm
parent77a41cb98c3c5d87a7b72c1f9ee7252d1709b926 (diff)
downloadguix-patches-a0461f9fbd7e641f520eb543e967e59afdae31ea.tar
guix-patches-a0461f9fbd7e641f520eb543e967e59afdae31ea.tar.gz
gnu: emacs-font-lock-studio: Follow packaging guidelines.
* gnu/packages/emacs-xyz.scm (emacs-font-lock-studio): Use git-version as outlined in the documentation on version numbers. For the base version, use "0.0.7" as specified in the "Version:" comment in the source and the README.
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm38
1 files changed, 20 insertions, 18 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index df34da9200..6482c9bfc3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3197,23 +3197,25 @@ that the binary uses instead of the actual binary contents.")
(license license:gpl3+)))
(define-public emacs-font-lock-studio
- (package
- (name "emacs-font-lock-studio")
- (version "20170127.2051") ;melpa version
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Lindydancer/font-lock-studio")
- (commit "12c35967b31233e06946c70627aa3152dacfe261")))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0q0s6f5vi3sfifj7vq2nnsmgyyivp1sd3idk32858md5ri71qif0"))))
- (build-system emacs-build-system)
- (home-page "https://github.com/Lindydancer/font-lock-studio")
- (synopsis "Interactive debugger for Font Lock keywords")
- (description
- "Font Lock Studio is an interactive debugger for Emacs syntax highlighting
+ (let ((commit "12c35967b31233e06946c70627aa3152dacfe261")
+ (revision "1"))
+ (package
+ (name "emacs-font-lock-studio")
+ (version (git-version "0.0.7" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Lindydancer/font-lock-studio")
+ (commit "12c35967b31233e06946c70627aa3152dacfe261")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0q0s6f5vi3sfifj7vq2nnsmgyyivp1sd3idk32858md5ri71qif0"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/Lindydancer/font-lock-studio")
+ (synopsis "Interactive debugger for Font Lock keywords")
+ (description
+ "Font Lock Studio is an interactive debugger for Emacs syntax highlighting
rules, also called Font Lock keywords. It can @emph{single-step} Font Lock
keywords -- matchers, highlights, and anchored rules, to see what happens when
a buffer is fontified. Breakpoints can be set on or inside rules. When
@@ -3221,7 +3223,7 @@ inside a rule, matches are visualized using a palette of background colors.
The explainer can describe a rule in plain-text English. Finally, tight
integration with Edebug allows stepping into Lisp expressions that are part of
the Font Lock keywords.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-form-feed
(package