summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-07-14 11:58:13 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-07-14 11:58:13 +0200
commit8615bcbe20b5172e5075d525748e4f70d2f7e6f9 (patch)
treef062ad4b99418e220f233657cd364a01752b5430 /gnu/packages/emacs-xyz.scm
parent9e43129bf8373843c249100444b905e4f0c0948b (diff)
downloadguix-patches-8615bcbe20b5172e5075d525748e4f70d2f7e6f9.tar
guix-patches-8615bcbe20b5172e5075d525748e4f70d2f7e6f9.tar.gz
gnu: Add emacs-counsel-notmuch.
* gnu/packages/emacs-xyz.scm (emacs-counsel-notmuch): New variable.
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c941323a4e..537638bd36 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -7041,6 +7041,46 @@ The purpose of this library is to wrap all the quirks and hassle of
@code{package.el} into a sane API.")
(license license:gpl3+)))
+(define-public emacs-counsel-notmuch
+ ;; Upstream provides no release. Extract version for main file.
+ (let ((commit "a4a1562935e4180c42524c51609d1283e9be0688")
+ (revision "0"))
+ (package
+ (name "emacs-counsel-notmuch")
+ (version (git-version "1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fuxialexander/counsel-notmuch.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "01k1321d961kc2i660a5595bqk0d85f16snsxngsn5si6y83kqr7"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'locate-notmuch
+ (lambda* (#:key inputs #:allow-other-keys)
+ (make-file-writable "counsel-notmuch.el")
+ (emacs-substitute-variables "counsel-notmuch.el"
+ ("counsel-notmuch-path"
+ (string-append (assoc-ref inputs "notmuch")
+ "/bin/notmuch")))
+ #t)))))
+ (inputs
+ `(("emacs-counsel" ,emacs-counsel)
+ ("notmuch" ,notmuch)
+ ("emacs-s" ,emacs-s)))
+ (home-page "https://github.com/fuxialexander/counsel-notmuch")
+ (synopsis "Search emails in Notmuch asynchronously with Ivy")
+ (description
+ "This package can be used to search emails in Notmuch
+asynchronously, with Counsel and Ivy. Simply call
+@code{counsel-notmuch} and input your Notmuch query.")
+ (license license:gpl3+))))
+
(define-public emacs-counsel-projectile
(package
(name "emacs-counsel-projectile")