summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorEugene Klimov via Guix-patches via <guix-patches@gnu.org>2021-04-06 01:08:07 +0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-04-11 11:07:07 +0200
commit735527d8e944099a587e40ecbcb4782309073bb2 (patch)
tree51601311847eb606f26937c8135725aff87ec606 /gnu/packages/emacs-xyz.scm
parent46c6161ed638ecde5e55211903be46deb22b5e93 (diff)
downloadguix-patches-735527d8e944099a587e40ecbcb4782309073bb2.tar
guix-patches-735527d8e944099a587e40ecbcb4782309073bb2.tar.gz
gnu: Add emacs-mode-line-idle.
* gnu/packages/emacs-xyz.scm (emacs-mode-line-idle): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2c43b1a5b2..a927aea227 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -96,6 +96,7 @@
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2021 Eugene Klimov <lipklim@mailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4680,6 +4681,32 @@ Also included are keybindings for spec files and Dired buffers, as well as
snippets for yasnippet.")
(license license:gpl3+))))
+(define-public emacs-mode-line-idle
+ ;; Package has no release. Version is extracted from "Version:" keyword in
+ ;; main file.
+ (let ((commit "02b1da6278e43cc9cc0356110cc6bfbb37eb8241")
+ (revision "1"))
+ (package
+ (name "emacs-mode-line-idle")
+ (version (git-version "0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (file-name (git-file-name name version))
+ (uri (git-reference
+ (url "https://gitlab.com/ideasman42/emacs-mode-line-idle")
+ (commit commit)))
+ (sha256
+ (base32 "0ky330b2sfbzkbxbfp9b21hdywsjw26bllspglz08hrbni7jmry8"))))
+ (build-system emacs-build-system)
+ (home-page "https://gitlab.com/ideasman42/emacs-mode-line-idle")
+ (synopsis "Simple delayed text evaluation for the mode-line")
+ (description
+ "Mode Line Idle provides a convenient way to defer text evaluation
+which integrates into existing mode-line without requiring a minor mode or
+configuration.")
+ (license license:gpl3+))))
+
(define-public emacs-smart-mode-line
(package
(name "emacs-smart-mode-line")
@@ -27597,3 +27624,4 @@ complementary packages.")
quasi-prefix map, with many useful bindings. These bindings are
shorter than usual, using mostly unprefixed keys.")
(license license:gpl3+)))
+