summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-03-03 09:57:36 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-03-03 09:57:36 +0100
commit72fdf85fadbed18bd4a64d3b735dfb4ad9f7201c (patch)
treea257b1a7174f8b0c87c56ca4bd32622267140a8f /gnu/packages/emacs-xyz.scm
parent2197c08428bb31e3869b63db88cc886d098b1620 (diff)
downloadguix-patches-72fdf85fadbed18bd4a64d3b735dfb4ad9f7201c.tar
guix-patches-72fdf85fadbed18bd4a64d3b735dfb4ad9f7201c.tar.gz
gnu: Add emacs-spacemacs-theme.
* gnu/packages/emacs-xyz.scm (emacs-spacemacs-theme): New variable.
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1fae2423f9..eb1e68deae 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -20399,6 +20399,31 @@ displayed against a dark background (Modus Vivendi).")
color. Designed for 256-color terminals. Comes in light and dark!")
(license license:gpl3+))))
+(define-public emacs-spacemacs-theme
+ (let ((commit "e088bff4f190495615c29de93079aaa823e2300c")
+ (revision "0"))
+ (package
+ (name "emacs-spacemacs-theme")
+ (version (git-version "0" revision commit)) ;no release yet
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nashamri/spacemacs-theme.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "09p5pzy3ibrl8dxmg10v8j16wxdn1fkdqpbi8l9pgfib2azmnvnc"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/nashamri/spacemacs-theme")
+ (synopsis
+ "Light and dark theme for spacemacs that supports GUI and terminal")
+ (description
+ "Spacemacs theme is an Emacs color theme that started as
+a theme for Spacemacs. The theme comes with dark and light variants
+and it should work well with 256 color terminals.")
+ (license license:gpl3+))))
+
(define-public emacs-elixir-mode
(package
(name "emacs-elixir-mode")