summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-04-17 19:06:27 +0200
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-05-01 15:56:39 +0200
commit710cdcc9ce4b93e4e4830aaec874d557198dd761 (patch)
treea048bce15ad1d23afd39ecba0ab797ef36fe532d /gnu/packages/emacs-xyz.scm
parentd34e6dbc4b5451ce7fd4f9e28ad7efe12add9c80 (diff)
downloadguix-patches-710cdcc9ce4b93e4e4830aaec874d557198dd761.tar
guix-patches-710cdcc9ce4b93e4e4830aaec874d557198dd761.tar.gz
gnu: emacs-pdf-tools: Adjust to changes in emacs-build-system.
* gnu/packages/emacs-xyz.scm (emacs-pdf-tools)[#:phases]: Rename 'emacs-add-source-to-load-path' to 'emacs-expand-load-path'. Use expand-load-path, which replaces add-source-to-load-path. Signed-off-by: Leo Prikler <leo.prikler@student.tugraz.at>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a5cde18173..63be594da3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2995,8 +2995,8 @@ during idle time, while Emacs is doing nothing else.")
;; upgrading" that pdf-tools tries to perform.
(emacs-substitute-variables "pdf-tools.el"
("pdf-tools-handle-upgrades" '()))))
- (add-after 'emacs-patch-variables 'emacs-add-source-to-load-path
- (assoc-ref emacs:%standard-phases 'add-source-to-load-path))
+ (add-after 'emacs-patch-variables 'emacs-expand-load-path
+ (assoc-ref emacs:%standard-phases 'expand-load-path))
(add-after 'emacs-add-source-to-load-path 'emacs-install
(assoc-ref emacs:%standard-phases 'install))
(add-after 'emacs-install 'emacs-build