summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorAuPath <marco.au.grassi98@protonmail.com>2020-11-16 15:26:04 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-11-16 20:19:53 +0100
commit4ef38c806df297c3f9458bdb163f2954a6521422 (patch)
tree3ee4e5cbf7f0b83625a0ba8b705d643dc006822e /gnu/packages/emacs-xyz.scm
parent322faf8e997f17af8df76a247696d7b7137f19b4 (diff)
downloadguix-patches-4ef38c806df297c3f9458bdb163f2954a6521422.tar
guix-patches-4ef38c806df297c3f9458bdb163f2954a6521422.tar.gz
gnu: Add emacs-boon.
* gnu/packages/emacs-xyz.scm (emacs-boon): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 59e2db175a..94e553f5ae 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -11371,6 +11371,35 @@ constructs.")
configuration of Chinese fonts.")
(license license:gpl2+)))
+(define-public emacs-boon
+ (package
+ (name "emacs-boon")
+ (version "1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jyp/boon")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ss9bjs34q41pa0g0nbdzd8fwpjcbd2239rdlx5aykfv9v0b8j77"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-expand-region" ,emacs-expand-region)
+ ("emacs-multiple-cursors" ,emacs-multiple-cursors)
+ ("emacs-powerline" ,emacs-powerline)
+ ("emacs-spaceline" ,emacs-spaceline)))
+ (home-page "https://github.com/jyp/boon")
+ (synopsis "Ergonomic command mode for Emacs")
+ (description "Boon is a complete package for modal editing with a focus on
+ergonomics and modularity. Spacial allocation of keys comes first, mnemonics
+second. Most common operations are mapped to the home row, common editing
+commands are bound to keys reachable with the left hand and movement keys are
+reached with the right hand.")
+ (license license:gpl3+)))
+
(define-public emacs-csharp-mode
(package
(name "emacs-csharp-mode")