summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorJoseph LaFreniere <joseph@lafreniere.xyz>2020-11-11 00:39:58 -0600
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-04-11 11:27:45 +0200
commit432d801ddee6e4bd03c9d0771d35ee81080e8f20 (patch)
tree3d306be7b8a7fef4ca3db12c597b5133c47e648d /gnu/packages/emacs-xyz.scm
parent2d0a546508cb63e340220a363898fa9f46f03006 (diff)
downloadguix-patches-432d801ddee6e4bd03c9d0771d35ee81080e8f20.tar
guix-patches-432d801ddee6e4bd03c9d0771d35ee81080e8f20.tar.gz
gnu: Add emacs-ghq.
* gnu/packages/emacs-xyz.scm (emacs-ghq): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8111aacba7..d87acbe508 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -141,6 +141,7 @@
#:use-module (gnu packages djvu)
#:use-module (gnu packages ebook)
#:use-module (gnu packages emacs)
+ #:use-module (gnu packages golang)
#:use-module (gnu packages guile)
#:use-module (gnu packages gtk)
#:use-module (gnu packages gnome)
@@ -939,6 +940,29 @@ Files with the @file{.graphql} and @file{.gql} extensions are
automatically opened with this mode.")
(license license:gpl3+))))
+(define-public emacs-ghq
+ (package
+ (name "emacs-ghq")
+ (version "0.1.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rcoedo/emacs-ghq")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0rh2k93c3a0vl073a3s3a3h6gkw454v1lyd7y8l3pd24vw9hc628"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("ghq" ,ghq)))
+ (home-page "https://github.com/rcoedo/emacs-ghq")
+ (synopsis "Emacs interface for @code{ghq} tool")
+ (description
+ "This package provides a set of functions wrapping @code{ghq}, a tool for
+organizing remote Go repository clones.")
+ (license license:gpl3+)))
+
(define-public emacs-ghub
(package
(name "emacs-ghub")