summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorNiklas Eklund <niklas.eklund@posteo.net>2022-02-21 17:52:40 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-22 11:34:08 +0100
commit3d6f6aa65ede312a4ed900ed60f34dc49fb6a4f6 (patch)
treec8b8ed557852f412fca5cfd2124bc66f16c28938 /gnu/packages/emacs-xyz.scm
parent35080813bb9dca5ffad535eb7ac923ec779b7ab6 (diff)
downloadguix-patches-3d6f6aa65ede312a4ed900ed60f34dc49fb6a4f6.tar
guix-patches-3d6f6aa65ede312a4ed900ed60f34dc49fb6a4f6.tar.gz
gnu: Add emacs-highlight-doxygen.
* gnu/packages/emacs-xyz.scm (emacs-highlight-doxygen): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 5a8039f659..a5e3133c4e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27536,6 +27536,34 @@ Google guidelines.")
(home-page "https://github.com/flycheck/flycheck-google-cpplint")
(license license:gpl3+))))
+(define-public emacs-highlight-doxygen
+ ;; Upstream does not tag releases. Commit below matches version bump.
+ (let ((commit "eec4874e2e89d4eb39091aad89a67dff8f8ec84c"))
+ (package
+ (name "emacs-highlight-doxygen")
+ (version "0.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Lindydancer/highlight-doxygen")
+ (commit commit)))
+ (sha256
+ (base32
+ "0r3rv1px43r265716l3g20c1ss4381h1mc1kjxin22vdmrj6cmxy"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/Lindydancer/highlight-doxygen")
+ (synopsis "Highlight Doxygen comments in Emacs, including code blocks")
+ (description
+ "This package highlights Doxygen comments.
+
+In addition to highlighting Doxygen commands and their arguments, entire
+Doxygen comment are highlighted, making them stand out compared to other
+comments. The code blocks are highlighted according to the
+language they are written in.")
+ (license license:gpl3+))))
+
(define-public emacs-helm-fish-completion
(package
(name "emacs-helm-fish-completion")