summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2021-01-14 15:32:48 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-01-15 21:33:32 +0100
commit37d40e488b51d106e078d28ee340ac922710fc54 (patch)
tree51ec2a288b5975958374b8c8636d608d6734ac50 /gnu/packages/emacs-xyz.scm
parentc03875b0361f114634caeb54935fe37a9b7b05af (diff)
downloadguix-patches-37d40e488b51d106e078d28ee340ac922710fc54.tar
guix-patches-37d40e488b51d106e078d28ee340ac922710fc54.tar.gz
gnu: Add emacs-crdt.
* gnu/packages/emacs-xyz.scm (emacs-crdt): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ac6a63e6a7..de99227255 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16184,6 +16184,32 @@ dumb text search, @code{elisp-refs} actually parses the code, so it's never
confused by comments or @code{foo-bar} matching @code{foo}.")
(license license:gpl3+)))
+(define-public emacs-crdt
+ (let ((commit "44068ae505adf2c3a7bdbf6723a25fc45d6d1666")
+ (revision "0"))
+ (package
+ (name "emacs-crdt")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://code.librehq.com/qhong/crdt.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "130fkhvi757pfnbz70g6nw2n71k89cwwx7yzvsd5v177228c8w7w"))))
+ (build-system emacs-build-system)
+ (home-page "https://code.librehq.com/qhong/crdt.el")
+ (synopsis "Real-time collaborative editing environment")
+ (description
+ "@code{crdt.el} is a real-time collaborative editing environment for
+Emacs using Conflict-free Replicated Data Types. With it, you can share
+multiple buffer in one session, and see other users’ cursor and region. It
+also synchronizes Org mode folding status. It should work with all of Org
+mode.")
+ (license license:gpl3+))))
+
(define-public emacs-crux
(let ((commit "308f17d914e2cd79cbc809de66d02b03ceb82859")
(revision "2"))