summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorStefan Reichör <stefan@xsteve.at>2021-03-07 22:57:41 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-03-08 00:13:50 +0100
commit18aec6c93ad84069d70a6555c252e48a791a789c (patch)
treea0dff45154cc3ef16c01ad31a236a2c0772e44eb /gnu/packages/emacs-xyz.scm
parent89f5cec879473ded8f0ffb3e563f08efb0f71890 (diff)
downloadguix-patches-18aec6c93ad84069d70a6555c252e48a791a789c.tar
guix-patches-18aec6c93ad84069d70a6555c252e48a791a789c.tar.gz
gnu: Add emacs-tup-mode.
* gnu/packages/emacs-xyz.scm (emacs-tup-mode): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 960a5668ca..aeaedc2597 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -94,6 +94,7 @@
;;; Copyright © 2021 Yurii Kholodkov <urist.mckorobochka@gmail.com>
;;; Copyright © 2021 Alexey Abramov <levenson@mmer.org>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
+;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5313,6 +5314,28 @@ view the build status of those servers' build jobs, and possibly to trigger
build jobs.")
(license license:gpl3+)))
+(define-public emacs-tup-mode
+ (package
+ (name "emacs-tup-mode")
+ (version "1.3.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ejmr/tup-mode")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0asd024n5v23wdsg1959sszq568wg3a1bp4jrk0cllfji1z0n78y"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/ejmr/tup-mode")
+ (synopsis "Major mode for editing ``tupfiles'' used by the Tup build system")
+ (description
+ "Tup mode provides syntax highlighting for all of the elements of
+tupfiles, such as rule definitions, user-defined variables, macros, flags, bin
+variables, and so on. The mode also allows you to execute Tup commands.")
+ (license license:gpl3+)))
+
(define-public emacs-company
(package
(name "emacs-company")