summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorJoseph LaFreniere <joseph@lafreniere.xyz>2021-03-26 22:16:41 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-03-26 22:16:41 +0100
commit147b86ad30bb574e0d3b4e30486b70ae31fd16c3 (patch)
tree56fdf4da40ef4003176025f1491e0d8496b7347c /gnu/packages/emacs-xyz.scm
parent1d8e6eb06ef661a515d233ffce98a8c5aa161526 (diff)
downloadguix-patches-147b86ad30bb574e0d3b4e30486b70ae31fd16c3.tar
guix-patches-147b86ad30bb574e0d3b4e30486b70ae31fd16c3.tar.gz
gnu: Add emacs-cascading-dir-locals.
* gnu/packages/emacs-xyz.scm (emacs-cascading-dir-locals): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 645ccb8c36..ead2144b42 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -23391,6 +23391,39 @@ Dash docsets.")
through Dash docsets.")
(license license:expat))))
+(define-public emacs-cascading-dir-locals
+ (let ((release "0.1")
+ (revision "0")
+ (commit "efdf5e6d62b955ee0ca3c170eae1d388799f9fa0"))
+ (package
+ (name "emacs-cascading-dir-locals")
+ (version (git-version release revision commit))
+ (home-page "https://github.com/fritzgrabo/cascading-dir-locals")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1jwd99kk5l588n7wwi1x3b4bgimm66x1icna3n20pwaj49kf0zy8"))))
+ (build-system emacs-build-system)
+ (synopsis "Apply all @file{.dir-locals.el} from root to current directory")
+ (description
+ "This package provides a global minor mode that changes how Emacs
+handles the lookup of applicable dir-locals files (@file{.dir-locals.el}):
+instead of starting at the directory of the visited file and moving up the
+directory tree only until a first dir-locals file is found, collect and apply
+all (!) dir-locals files found from the current directory up to the root one.
+
+Values specified in files nearer to the current directory take precedence over
+values in files farther away from it.
+
+You might want to use this to globally set dir-local variables that apply to
+all of your projects, then override or add variables on a per-project basis.")
+ (license license:gpl3+))))
+
(define-public emacs-calibredb
(package
(name "emacs-calibredb")