summaryrefslogtreecommitdiff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-04-22 22:35:49 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-04-23 10:48:49 +0200
commit01b03c0a9af2b2f6e53ef69abeba2fcd031b79ad (patch)
treec79640b9c8c94cd4abacaf957ec66936124459a6 /gnu/packages/emacs-xyz.scm
parentd64a62a0059894d9afebd31410556a414152abc8 (diff)
downloadguix-patches-01b03c0a9af2b2f6e53ef69abeba2fcd031b79ad.tar
guix-patches-01b03c0a9af2b2f6e53ef69abeba2fcd031b79ad.tar.gz
gnu: Add emacs-shell-command+.
* gnu/packages/emacs-xyz.scm (emacs-shell-command+): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f7839cf6e6..35fc863a90 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27041,6 +27041,26 @@ Features:
@end itemize\n")
(license license:gpl3+)))
+(define-public emacs-shell-command+
+ (package
+ (name "emacs-shell-command+")
+ (version "2.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/"
+ "shell-command+-" version ".tar"))
+ (sha256
+ (base32 "1jyrnv89989bi03m5h8dj0cllsw3rvyxkiyfrh9v6gpxjwfy8lmq"))))
+ (build-system emacs-build-system)
+ (home-page "http://elpa.gnu.org/packages/shell-command+.html")
+ (synopsis "Extended Emacs @code{shell-command}")
+ (description
+ "Shell-command+ is a @code{shell-command} substitute that extends the
+regular Emacs command with several features. You can for example count all
+the lines in a buffer with @code{> wc -l}, or delete all lower case letters in
+the selected region with @code{| tr -d a-z}.")
+ (license license:gpl3+)))
+
(define-public emacs-shell-pop
(let ((commit "4b4394037940a890a313d715d203d9ead2d156a6")
(revision "0"))