summaryrefslogtreecommitdiff
path: root/gnu/packages/elm.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-16 09:42:08 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:50 -0500
commiteef308d62a488fe56344ba8f7949217fb8cba427 (patch)
tree08a214eb6b779aa867bc7f965a34ac809c96f95e /gnu/packages/elm.scm
parent3594b6699d3043029f85fda2ccd82da1ae17e61b (diff)
downloadguix-patches-eef308d62a488fe56344ba8f7949217fb8cba427.tar
guix-patches-eef308d62a488fe56344ba8f7949217fb8cba427.tar.gz
gnu: elm-compiler: Fix Cabal dependency constraints.
This package used a patch to update the Cabal version constraints for 'language-glsl'. This is now done in a phase for consistency with other Haskell packages. * gnu/packages/elm.scm (elm-compiler): Add a phase that updates the Cabal file to allow for newer versions of 'ansi-terminal', 'containers', 'http-client', 'language-glsl', and 'network'. [source]: Remove 'elm-compiler-relax-glsl-bound.patch'. * gnu/packages/patches/elm-compiler-relax-glsl-bound.patch: Delete file. * gnu/local.mk: Remove it.
Diffstat (limited to 'gnu/packages/elm.scm')
-rw-r--r--gnu/packages/elm.scm18
1 files changed, 17 insertions, 1 deletions
diff --git a/gnu/packages/elm.scm b/gnu/packages/elm.scm
index 8b5ec36621..feaa9c8d5c 100644
--- a/gnu/packages/elm.scm
+++ b/gnu/packages/elm.scm
@@ -47,9 +47,25 @@
(base32 "0s93z9vr0vp5w894ghc5s34nsq09sg1msf59zfiba87sid5vgjqy"))
(patches
(search-patches "elm-compiler-disable-reactor.patch"
- "elm-compiler-relax-glsl-bound.patch"
"elm-compiler-fix-map-key.patch"))))
(build-system haskell-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'update-constraints
+ (lambda _
+ (substitute* "elm.cabal"
+ (("ansi-terminal >= 0\\.8 && < 0\\.9,")
+ "ansi-terminal >= 0.8 && < 0.10,")
+ (("containers >= 0\\.5\\.8\\.2 && < 0\\.6,")
+ "containers >= 0.5.8.2 && < 0.7,")
+ (("http-client >= 0\\.5 && < 0\\.6,")
+ "http-client >= 0.5 && < 0.7,")
+ (("language-glsl >= 0\\.0\\.2 && < 0\\.3,")
+ "language-glsl >= 0.0.2 && < 0.4,")
+ (("network >= 2\\.4 && < 2\\.7,")
+ "network >= 2.4 && < 2.9,"))
+ #t)))))
(inputs
`(("ghc-ansi-terminal" ,ghc-ansi-terminal)
("ghc-ansi-wl-pprint" ,ghc-ansi-wl-pprint)