summaryrefslogtreecommitdiff
path: root/gnu/packages/elm.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-05-18 14:10:59 -0400
committerLudovic Courtès <ludo@gnu.org>2022-05-22 01:07:53 +0200
commitdb6b8d5e2c705b1e69815b2edae4117c76c9b2de (patch)
treee4a5eade9129c50709460dd97737a2ba74aee1b2 /gnu/packages/elm.scm
parent7ecc85525491986256af62febe3d154ebec9bc05 (diff)
downloadguix-patches-db6b8d5e2c705b1e69815b2edae4117c76c9b2de.tar
guix-patches-db6b8d5e2c705b1e69815b2edae4117c76c9b2de.tar.gz
gnu: Add elm-svg.
* gnu/packages/elm.scm (elm-svg): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/elm.scm')
-rw-r--r--gnu/packages/elm.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/elm.scm b/gnu/packages/elm.scm
index 98b60c48f7..5ba6743399 100644
--- a/gnu/packages/elm.scm
+++ b/gnu/packages/elm.scm
@@ -198,3 +198,25 @@ higher-level libraries directly.")
(synopsis "Fast HTML, rendered with virtual DOM diffing")
(description "This package provides Elm's HTML rendering library.")
(license license:bsd-3)))
+
+(define-public elm-svg
+ (package
+ (name "elm-svg")
+ (version "1.0.1")
+ (source
+ (elm-package-origin
+ "elm/svg"
+ version
+ (base32 "1iqsc3p129j56lp1y3z3mfc6x1shvrmx3pkhri2777ylhyw90qvl")))
+ (build-system elm-build-system)
+ (propagated-inputs
+ (list elm-html
+ elm-virtual-dom
+ elm-json
+ elm-core))
+ (home-page "https://package.elm-lang.org/packages/elm/svg/1.0.1")
+ (synopsis "Fast SVG, rendered with virtual DOM diffing")
+ (description
+ "This package provides Elm's @acronym{SVG, Scalable Vector Graphics}
+library.")
+ (license license:bsd-3)))