summaryrefslogtreecommitdiff
path: root/gnu/packages/elm.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-09-20 10:49:34 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-10-08 09:13:52 +0200
commitb97f549b14402421fcfb360ddd4cff7de93b9af0 (patch)
tree855c25f617f75e29e77ff2b52b754e1249164d30 /gnu/packages/elm.scm
parentb74ca403cbb11c60d57b6a0148d97c6572019754 (diff)
downloadguix-patches-b97f549b14402421fcfb360ddd4cff7de93b9af0.tar
guix-patches-b97f549b14402421fcfb360ddd4cff7de93b9af0.tar.gz
gnu: Update Haskell ecosystem.
Bump packages’ versions to the lastest Stackage or Hackage release. Since packages are interdependent, do so in a single commit. 525 packages have been updated. These packages have been removed, because they fail to build, have no newer version available and no dependencies: corrode ghc-easytest ghc-edisonapi ghc-edisoncore ghc-pandoc-types ghc-regex-tdfa-text These have been removed, because they are no longer required: ghc-happy-1.19.9 ghc-prettyprinter-1.6 ghc-protolude-0.3 ghc-pandoc-citeproc and pandoc-citeproc have been removed, because pandoc does not use them any more. Co-authored-by: Xinglu Chen <public@yoctocell.xyz>
Diffstat (limited to 'gnu/packages/elm.scm')
-rw-r--r--gnu/packages/elm.scm15
1 files changed, 3 insertions, 12 deletions
diff --git a/gnu/packages/elm.scm b/gnu/packages/elm.scm
index feaa9c8d5c..338008185d 100644
--- a/gnu/packages/elm.scm
+++ b/gnu/packages/elm.scm
@@ -52,20 +52,11 @@
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'update-constraints
+ (add-before 'configure 'update-constraints
(lambda _
(substitute* "elm.cabal"
- (("ansi-terminal >= 0\\.8 && < 0\\.9,")
- "ansi-terminal >= 0.8 && < 0.10,")
- (("containers >= 0\\.5\\.8\\.2 && < 0\\.6,")
- "containers >= 0.5.8.2 && < 0.7,")
- (("http-client >= 0\\.5 && < 0\\.6,")
- "http-client >= 0.5 && < 0.7,")
- (("language-glsl >= 0\\.0\\.2 && < 0\\.3,")
- "language-glsl >= 0.0.2 && < 0.4,")
- (("network >= 2\\.4 && < 2\\.7,")
- "network >= 2.4 && < 2.9,"))
- #t)))))
+ (("(ansi-terminal|containers|network|http-client|language-glsl)\\s+[^,]+" all dep)
+ dep)))))))
(inputs
`(("ghc-ansi-terminal" ,ghc-ansi-terminal)
("ghc-ansi-wl-pprint" ,ghc-ansi-wl-pprint)