summaryrefslogtreecommitdiff
path: root/gnu/packages/elm.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-05-18 14:11:14 -0400
committerLudovic Courtès <ludo@gnu.org>2022-05-22 01:07:55 +0200
commit34f4542154558388810258e49b7fe1c91bff9253 (patch)
tree5e3b32cc48cc6cf094535e1dd9d40b2cee8be8ed /gnu/packages/elm.scm
parent297ae57bed14abc5f949f36e6b98bad0f5a86993 (diff)
downloadguix-patches-34f4542154558388810258e49b7fe1c91bff9253.tar
guix-patches-34f4542154558388810258e49b7fe1c91bff9253.tar.gz
gnu: Add elm-danhandrea-elm-date-format.
* gnu/packages/elm.scm (elm-danhandrea-elm-date-format): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/elm.scm')
-rw-r--r--gnu/packages/elm.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/elm.scm b/gnu/packages/elm.scm
index edd13a0b8a..2e37f4c5fc 100644
--- a/gnu/packages/elm.scm
+++ b/gnu/packages/elm.scm
@@ -603,3 +603,22 @@ code. To actually run the tests, you need the command-line tool from
@url{https://github.com/rtfeldman/node-test-runner}, which has not yet been
packaged for Guix.")
(license license:bsd-3)))
+
+(define-public elm-danhandrea-elm-date-format
+ (package
+ (name "elm-danhandrea-elm-date-format")
+ (version "2.0.1")
+ (source
+ (elm-package-origin
+ "danhandrea/elm-date-format"
+ version
+ (base32 "03mglzyywij5sm56m7q2jhhbsv7f9rdirgwmq0q41ghir81bzpv6")))
+ (build-system elm-build-system)
+ (propagated-inputs (list elm-time elm-core))
+ (inputs (list elm-explorations-test))
+ (home-page
+ "https://package.elm-lang.org/packages/danhandrea/elm-date-format/2.0.1")
+ (synopsis "Date formatting for Elm")
+ (description "This package enhances @code{elm/time} with support for
+format strings and internationalization of dates.")
+ (license license:bsd-3)))