summaryrefslogtreecommitdiff
path: root/gnu/packages/elixir.scm
diff options
context:
space:
mode:
authorOskar Köök <oskarkook@maatriks.ee>2019-10-24 23:37:38 +0300
committerLudovic Courtès <ludo@gnu.org>2019-11-16 17:43:49 +0100
commit2148e68d333f0dbd3c455bc1ced4ffa4361ede3d (patch)
tree727240d080261bdcf0b0c099074214e978f07554 /gnu/packages/elixir.scm
parentb1077c2234c47902990a6d27f471fd6b23a2df06 (diff)
downloadguix-patches-2148e68d333f0dbd3c455bc1ced4ffa4361ede3d.tar
guix-patches-2148e68d333f0dbd3c455bc1ced4ffa4361ede3d.tar.gz
gnu: elixir: Update to 1.9.2.
* gnu/packages/elixir.scm (elixir): Update to 1.9.2. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/elixir.scm')
-rw-r--r--gnu/packages/elixir.scm20
1 files changed, 16 insertions, 4 deletions
diff --git a/gnu/packages/elixir.scm b/gnu/packages/elixir.scm
index 88ada71aea..144a8cc4e7 100644
--- a/gnu/packages/elixir.scm
+++ b/gnu/packages/elixir.scm
@@ -33,7 +33,7 @@
(define-public elixir
(package
(name "elixir")
- (version "1.8.2")
+ (version "1.9.2")
(source
(origin
(method git-fetch)
@@ -42,7 +42,7 @@
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1n77cpcl2b773gmj3m9s24akvj9gph9byqbmj2pvlsmby4aqwckq"))
+ (base32 "19yn6nx6r627f5zbyc7ckgr96d6b45sgwx95n2gp2imqwqvpj8wc"))
(patches (search-patches "elixir-path-length.patch"))))
(build-system gnu-build-system)
(arguments
@@ -63,9 +63,21 @@
"lib/mix/lib/mix/scm/git.ex")
(("(cmd\\(['\"])git" _ prefix)
(string-append prefix (which "git"))))
+ (substitute* '("lib/mix/lib/mix/release.ex"
+ "lib/mix/lib/mix/tasks/release.init.ex")
+ (("#!/bin/sh")
+ (string-append "#!" (which "sh"))))
(substitute* "bin/elixir"
- (("ERL_EXEC=\"erl\"")
- (string-append "ERL_EXEC=" (which "erl"))))
+ (("ERTS_BIN=")
+ (string-append
+ "ERTS_BIN="
+ ;; Elixir Releases will prepend to ERTS_BIN the path of a copy of erl.
+ ;; We detect if a release is being generated by checking the initial ERTS_BIN
+ ;; value: if it's empty, we are not in release mode and can point to the actual
+ ;; erl binary in Guix store.
+ "\nif [ -z \"$ERTS_BIN\" ]; then ERTS_BIN="
+ (string-drop-right (which "erl") 3)
+ "; fi")))
(substitute* "bin/mix"
(("#!/usr/bin/env elixir")
(string-append "#!" out "/bin/elixir"))))