summaryrefslogtreecommitdiff
path: root/gnu/packages/elf.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-02-21 20:05:40 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-02-21 21:14:48 +0200
commitdb700d58299dd0a063622de519ae42afe33c3ee5 (patch)
tree5682fb6dcca7a5b1e1c38f9a58b55ba4ce451bec /gnu/packages/elf.scm
parenteb9a603317c4b8a77079f0a9ebd3ea802a0ed8df (diff)
downloadguix-patches-db700d58299dd0a063622de519ae42afe33c3ee5.tar
guix-patches-db700d58299dd0a063622de519ae42afe33c3ee5.tar.gz
gnu: libelf: Use 'modify-phases'.
* gnu/packages/elf.scm (libelf)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu/packages/elf.scm')
-rw-r--r--gnu/packages/elf.scm32
1 files changed, 16 insertions, 16 deletions
diff --git a/gnu/packages/elf.scm b/gnu/packages/elf.scm
index 95ba7618a1..c68604cf83 100644
--- a/gnu/packages/elf.scm
+++ b/gnu/packages/elf.scm
@@ -79,22 +79,22 @@ addr2line, and more.")
(base32
"0vf7s9dwk2xkmhb79aigqm0x0yfbw1j0b9ksm51207qwr179n6jr"))))
(build-system gnu-build-system)
- (arguments `(#:phases (alist-replace
- 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- ;; This old `configure' script doesn't support
- ;; variables passed as arguments.
- (let ((out (assoc-ref outputs "out")))
- (setenv "CONFIG_SHELL" (which "bash"))
- (zero?
- (system* "./configure"
- (string-append "--prefix=" out)
- ,@(if (string=? "aarch64-linux"
- (%current-system))
- '("--host=aarch64-unknown-linux-gnu")
- '())
- ))))
- %standard-phases)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; This old `configure' script doesn't support
+ ;; variables passed as arguments.
+ (let ((out (assoc-ref outputs "out")))
+ (setenv "CONFIG_SHELL" (which "bash"))
+ (zero?
+ (system* "./configure"
+ (string-append "--prefix=" out)
+ ,@(if (string=? "aarch64-linux"
+ (%current-system))
+ '("--host=aarch64-unknown-linux-gnu")
+ '())))))))))
(home-page "http://www.mr511.de/software/english.html")
(synopsis "ELF object file access library")
(description "Libelf is a C library to access ELF object files.")