summaryrefslogtreecommitdiff
path: root/gnu/packages/elf.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/elf.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/elf.scm')
-rw-r--r--gnu/packages/elf.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/elf.scm b/gnu/packages/elf.scm
index 2bc1d00048..d4f75c9726 100644
--- a/gnu/packages/elf.scm
+++ b/gnu/packages/elf.scm
@@ -100,8 +100,8 @@
(("run-backtrace-native.sh") ""))
#t)))))
- (native-inputs `(("m4" ,m4)))
- (inputs `(("zlib" ,zlib)))
+ (native-inputs (list m4))
+ (inputs (list zlib))
(home-page "https://sourceware.org/elfutils/")
(synopsis "Collection of utilities and libraries to handle ELF files and
DWARF data")
@@ -175,8 +175,8 @@ object or archive file), @command{eu-strip} (for discarding symbols),
("python-sphinx" ,python-sphinx)
("python" ,python))) ;for tests
(propagated-inputs
- `(("elfutils" ,elfutils) ;libabigail.la says -lelf
- ("libxml2" ,libxml2))) ;in Requires.private of libabigail.pc
+ (list elfutils ;libabigail.la says -lelf
+ libxml2)) ;in Requires.private of libabigail.pc
(synopsis "Analyze application binary interfaces (ABIs)")
(description
"@dfn{ABIGAIL} stands for the Application Binary Interface Generic
@@ -230,9 +230,9 @@ static analysis of the ELF binaries at hand.")
"/" file) "."))
'("config.sub" "config.guess")))))))
(native-inputs
- `(("autoconf" ,autoconf)
- ;; For up-to-date 'config.guess' and 'config.sub'
- ("automake" ,automake)))
+ (list autoconf
+ ;; For up-to-date 'config.guess' and 'config.sub'
+ automake))
(home-page (string-append "https://web.archive.org/web/20181111033959/"
"http://www.mr511.de/software/english.html"))
(synopsis "ELF object file access library")