summaryrefslogtreecommitdiff
path: root/gnu/packages/elf.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-12-15 23:19:44 +0100
committerLudovic Courtès <ludo@gnu.org>2013-12-15 23:19:44 +0100
commit2ed5b0f42c40b5eb8df462b3cff3399123423182 (patch)
treec53d8dfefb04edb7580dcae3ef597c19d70db893 /gnu/packages/elf.scm
parentc4c4cc05979f2a2d0212963c5fe1b940d63a0958 (diff)
downloadguix-patches-2ed5b0f42c40b5eb8df462b3cff3399123423182.tar
guix-patches-2ed5b0f42c40b5eb8df462b3cff3399123423182.tar.gz
gnu: Add elfutils.
* gnu/packages/elf.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/packages/elf.scm')
-rw-r--r--gnu/packages/elf.scm53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnu/packages/elf.scm b/gnu/packages/elf.scm
new file mode 100644
index 0000000000..83ec8fbc5c
--- /dev/null
+++ b/gnu/packages/elf.scm
@@ -0,0 +1,53 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages elf)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module ((guix licenses) #:select (lgpl3+))
+ #:use-module (gnu packages m4)
+ #:use-module (gnu packages compression))
+
+(define-public elfutils
+ (package
+ (name "elfutils")
+ (version "0.157")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://fedorahosted.org/releases/e/l/elfutils/"
+ version "/elfutils-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "11ffbihw9zs2dhmlww9zilwvmv6v1pr6bvnz5dnzn0lxq70ckbag"))))
+ (build-system gnu-build-system)
+
+ ;; Separate programs because that's usually not what elfutils users want,
+ ;; and because they duplicate what Binutils provides.
+ (outputs '("out" ; libelf.so, elfutils/*.h, etc.
+ "bin")) ; ld, nm, objdump, etc.
+
+ (native-inputs `(("m4" ,m4)))
+ (inputs `(("zlib" ,zlib)))
+ (home-page "https://fedorahosted.org/elfutils/")
+ (synopsis #f)
+ (description #f)
+
+ ;; Libraries are dual-licensed LGPLv3.0+ | GPLv2, and programs are GPLv3+.
+ (license lgpl3+)))