summaryrefslogtreecommitdiff
path: root/gnu/packages/elf.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-23 02:56:47 -0400
committerMark H Weaver <mhw@netris.org>2018-03-23 04:42:40 -0400
commit257d8974e6593dc84fde42553934b1d9e40ec586 (patch)
tree73c38ab4aafbb52406f6a2c6df8c1141a43141b0 /gnu/packages/elf.scm
parent1a3aa5bab2f9ceb657c862017af62fa295834f98 (diff)
downloadguix-patches-257d8974e6593dc84fde42553934b1d9e40ec586.tar
guix-patches-257d8974e6593dc84fde42553934b1d9e40ec586.tar.gz
gnu: libelf: Use invoke.
* gnu/packages/elf.scm (libelf)[arguments]: Use invoke in the configure phase.
Diffstat (limited to 'gnu/packages/elf.scm')
-rw-r--r--gnu/packages/elf.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/elf.scm b/gnu/packages/elf.scm
index 08d92532fa..fa1fb46aa4 100644
--- a/gnu/packages/elf.scm
+++ b/gnu/packages/elf.scm
@@ -90,13 +90,12 @@ Executable and Linkable Format (@dfn{ELF}). This includes @command{ld},
;; variables passed as arguments.
(let ((out (assoc-ref outputs "out")))
(setenv "CONFIG_SHELL" (which "bash"))
- (zero?
- (system* "./configure"
- (string-append "--prefix=" out)
+ (invoke "./configure"
+ (string-append "--prefix=" out)
,@(if (string=? "aarch64-linux"
(%current-system))
'("--host=aarch64-unknown-linux-gnu")
- '())))))))))
+ '()))))))))
(home-page "http://www.mr511.de/software/english.html")
(synopsis "ELF object file access library")
(description "Libelf is a C library to access ELF object files.")