summaryrefslogtreecommitdiff
path: root/gnu/packages/electronics.scm
diff options
context:
space:
mode:
authorTheodoros Foradis <theodoros.for@openmailbox.org>2017-06-24 00:05:12 +0300
committerDanny Milosavljevic <dannym@scratchpost.org>2017-06-24 07:47:38 +0200
commit03d0cc116001d2bac4204925c9d169ec3a58323f (patch)
tree99fc9a2ba3327e670167453d1a13dd7a7095bf4d /gnu/packages/electronics.scm
parent06de4aaf1e71916181c87997b62698a09db35009 (diff)
downloadguix-patches-03d0cc116001d2bac4204925c9d169ec3a58323f.tar
guix-patches-03d0cc116001d2bac4204925c9d169ec3a58323f.tar.gz
gnu: Add libserialport.
* gnu/packages/electronics.scm: New file. (libserialport): New variable. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/electronics.scm')
-rw-r--r--gnu/packages/electronics.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/electronics.scm b/gnu/packages/electronics.scm
new file mode 100644
index 0000000000..4abe9eea65
--- /dev/null
+++ b/gnu/packages/electronics.scm
@@ -0,0 +1,44 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2017 Theodoros Foradis <theodoros.for@openmailbox.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages electronics)
+ #:use-module (guix utils)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages))
+
+(define-public libserialport
+ (package
+ (name "libserialport")
+ (version "0.1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://sigrok.org/download/source/libserialport/libserialport-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "17ajlwgvyyrap8z7f16zcs59pksvncwbmd3mzf98wj7zqgczjaja"))))
+ (build-system gnu-build-system)
+ (home-page "http://sigrok.org/wiki/Libserialport")
+ (synopsis "Library for using serial ports")
+ (description "Libserialport is a minimal shared library written in C that is intended
+to take care of the OS-specific details when writing software that uses serial ports.")
+ (license license:lgpl3+)))