summaryrefslogtreecommitdiff
path: root/gnu/packages/efi.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2019-01-23 01:03:01 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2019-02-04 00:14:16 +0100
commitf8ff37d6c093e7cab16d1987139b4df92a7ae4ab (patch)
treec13486a2e01c01d603a548fb28d1dab4beeec295 /gnu/packages/efi.scm
parent7c4700e9f9c290ecc08a4da41534063565fccb25 (diff)
downloadguix-patches-f8ff37d6c093e7cab16d1987139b4df92a7ae4ab.tar
guix-patches-f8ff37d6c093e7cab16d1987139b4df92a7ae4ab.tar.gz
gnu: Add gnu-efi.
* gnu/packages/efi.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/packages/efi.scm')
-rw-r--r--gnu/packages/efi.scm52
1 files changed, 52 insertions, 0 deletions
diff --git a/gnu/packages/efi.scm b/gnu/packages/efi.scm
new file mode 100644
index 0000000000..f76b600ec8
--- /dev/null
+++ b/gnu/packages/efi.scm
@@ -0,0 +1,52 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 Danny Milosavljevic <dannym@scratchpost.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages efi)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix download)
+ #:use-module (guix packages)
+ #:use-module (guix utils))
+
+(define-public gnu-efi
+ (package
+ (name "gnu-efi")
+ (version "3.0.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/gnu-efi/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1w3p4aqlc5j93q44la7dc8cr3hky20zvsd0h0k2lyzhwmrzfl5b7"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; None exist.
+ #:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (synopsis "EFI toolchain")
+ (description "This package provides an EFI (Extensible Firmware
+Interface) toolchain for building programs that can run in the
+environment presented by Intel's EFI.")
+ (home-page "https://directory.fsf.org/wiki/GNU_EFI")
+ ;; Distribution is allowed only when accepting all those licenses.
+ (license (list license:bsd-2 license:bsd-3 license:bsd-4 license:expat))))