summaryrefslogtreecommitdiff
path: root/gnu/packages/education.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-07-16 15:39:51 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-24 16:23:22 +0200
commitbf182596a9d85604f6f029302671a38001575355 (patch)
treeab99ec4b5db48abf76ea81d709f20c6486688567 /gnu/packages/education.scm
parent6ea7297ea49f6c704afb727a5afe7ef9ce4a4f73 (diff)
downloadguix-patches-bf182596a9d85604f6f029302671a38001575355.tar
guix-patches-bf182596a9d85604f6f029302671a38001575355.tar.gz
gnu: Use 'search-input-directory' for the SDL header directory.
* gnu/packages/education.scm (gcompris)[arguments]: Use 'search-input-directory' when searching for SDL headers. * gnu/packages/education.scm (t4k-common): Likewise. (tuxmath): Likewise. * gnu/packages/game-development.scm (tesseract-engine): Likewise. * gnu/packages/games.scm (foobillard++): Likewise. (ltris): Likewise. (prboom-plus): Likewise. (abbaye): Likewise. (red-eclipse): Likewise. (kiki): Likewise. (tome4): Likewise. (btanks): Likewise. (4dtris): Likewise. (edgar): Likewise. * gnu/packages/python-xyz.scm (python-kivy): Likewise.
Diffstat (limited to 'gnu/packages/education.scm')
-rw-r--r--gnu/packages/education.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index efe210e1ec..02aacf353c 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -101,10 +101,9 @@
(add-after 'set-paths 'set-sdl-paths
(lambda* (#:key inputs #:allow-other-keys)
(setenv "CPATH"
- (string-append (assoc-ref inputs "sdl-mixer")
- "/include/SDL:"
- (or (getenv "CPATH") "")))
- #t)))))
+ (string-append
+ (search-input-directory inputs "include/SDL")
+ ":" (or (getenv "CPATH") ""))))))))
(inputs
`(("gtk+" ,gtk+-2)
("librsvg" ,librsvg)
@@ -949,9 +948,10 @@ endless. For example:
(modify-phases %standard-phases
(add-after 'set-paths 'set-sdl-paths
(lambda* (#:key inputs #:allow-other-keys)
- (setenv "CPATH" (string-append (assoc-ref inputs "sdl")
- "/include/SDL:"
- (or (getenv "CPATH") "")))))
+ (setenv "CPATH"
+ (string-append
+ (search-input-directory inputs "/include/SDL")
+ ":" (or (getenv "CPATH") "")))))
(add-after 'unpack 'fix-andika-font-path
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "src/t4k_sdl.c"
@@ -1000,10 +1000,10 @@ TuxMath and TuxType.")
(add-after 'set-paths 'set-sdl-paths
(lambda* (#:key inputs #:allow-other-keys)
(setenv "CPATH"
- (string-append (assoc-ref inputs "sdl")
- "/include/SDL:"
- (or (getenv "CPATH") "")))
- #t))
+ (string-append
+ (search-input-directory inputs "/include/SDL")
+ ":"
+ (or (getenv "CPATH") "")))))
(add-after 'install 'install-desktop-file
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))