summaryrefslogtreecommitdiff
path: root/gnu/packages/education.scm
diff options
context:
space:
mode:
authornixo <nicolo@nixo.xyz>2021-05-25 09:02:41 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-05-25 12:11:18 +0200
commita68cca64cd92b36d6f5e887d43f591f356e0a237 (patch)
tree2fe6656f4d68fdbae7c19c6c417a23b6d3a76368 /gnu/packages/education.scm
parenta443181d7b6fcefa0e4cc32a078949fd6c7648c0 (diff)
downloadguix-patches-a68cca64cd92b36d6f5e887d43f591f356e0a237.tar
guix-patches-a68cca64cd92b36d6f5e887d43f591f356e0a237.tar.gz
gnu: Add kanatest.
* gnu/packages/education.scm (kanatest): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/education.scm')
-rw-r--r--gnu/packages/education.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 0986d2a19e..1f39e2afd2 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;; Copyright © 2020 Prafulla Giri <pratheblackdiamond@gmail.com>
+;;; Copyright © 2021 Nicolò Balzarotti <nicolo@nixo.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -727,6 +728,43 @@ languages and keyboard layouts, and typing statistics are used to dynamically
adjust the level of difficulty.")
(license license:gpl2)))
+(define-public kanatest
+ ;; Latest release tarball is 0.4.8, which is really old and does not build
+ ;; commit on sourceforge are not tagged, we take the latest
+ (let ((commit "860e790a35f547cc96669f805d371a5ba3d8daff")
+ (revision "0"))
+ (package
+ (name "kanatest")
+ (version (git-version "0.4.10" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.code.sf.net/p/kanatest/code")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0dz63m9p4ggzw0yb309qmgnl664qb5q268vaa3i9v0i8qsl66d78"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("gettext" ,gettext-minimal) ; for msgfmt
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libxml2" ,libxml2)
+ ("gtk+" ,gtk+)))
+ (home-page "https://kanatest.sourceforge.io/")
+ (synopsis "Hiragana and Katakana simple flashcard tool")
+ (description "Kanatest is a Japanese kana (Hiragana and Katakana) simple
+flashcard tool.
+
+During test the Kanatest displays randomly selected kana char (respecting mode
+and lesson) and waits for user answer expected as romaji equivalent. This
+process continues until all questions will be answered or all questions will
+be answered correctly (depends on options). At the end of test a short info
+about drilling time and correctness ratio is displayed. The results are
+stored and user can review his performance in any time.")
+ (license license:gpl2+))))
+
(define-public anki
(package
(name "anki")