summaryrefslogtreecommitdiff
path: root/gnu/packages/education.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-10-12 16:50:47 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-12 17:46:23 +0000
commita1eca979fb8da842e73c42f4f53be29b169810f2 (patch)
tree681c7283e412bb8a29c2531c4408b49c3e184764 /gnu/packages/education.scm
parent48d86a9ec6d8d2e97da2299ea41a03ef4cdaab83 (diff)
parent371aa5777a3805a3886f3feea5f1960fe3fe4219 (diff)
downloadguix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar
guix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen.
Diffstat (limited to 'gnu/packages/education.scm')
-rw-r--r--gnu/packages/education.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index bac3148c54..716f15a9db 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -650,14 +650,16 @@ Portuguese, Spanish and Italian.")
(define-public fet
(package
(name "fet")
- (version "6.0.4")
+ (version "6.1.8")
(source
(origin
(method url-fetch)
- (uri (string-append "https://www.lalescu.ro/liviu/fet/download/"
- "fet-" version ".tar.bz2"))
+ (uri (let ((directory "https://www.lalescu.ro/liviu/fet/download/")
+ (base (string-append "fet-" version ".tar.bz2")))
+ (list (string-append directory base)
+ (string-append directory "old/" base))))
(sha256
- (base32 "16yajwbvm2ain1p2h81qfm8pbrdp70zljck67j9yijwyr6xqdj2a"))))
+ (base32 "16m20vbhv8i7saxqb731bhds1f86d6x1f935j3ivg357805fqzll"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -668,8 +670,7 @@ Portuguese, Spanish and Italian.")
"src/src.pro"
"src/src-cl.pro"
"src/interface/fet.cpp")
- (("/usr") (assoc-ref outputs "out")))
- #t))
+ (("/usr") (assoc-ref outputs "out")))))
(replace 'configure
(lambda _ (invoke "qmake" "fet.pro"))))))
(inputs