summaryrefslogtreecommitdiff
path: root/gnu/packages/education.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-30 22:39:55 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-01 20:24:47 +0100
commit7d796d8068e25595905e30e3e220feb79946d25e (patch)
tree1bf572c9cec4c763b77d9eab495dc4097797a2d8 /gnu/packages/education.scm
parent2f57e34bf37a4920dd3c9a0d0bf6d06dda3d57eb (diff)
downloadguix-patches-7d796d8068e25595905e30e3e220feb79946d25e.tar
guix-patches-7d796d8068e25595905e30e3e220feb79946d25e.tar.gz
gnu: ktouch: Use qt-build-system.
* gnu/packages/display-managers.scm (ktouch): Use qt-build-sytem. [arguments]<modules, imported-modules>: Remove. <phases>: Base on phases from qt-build-system. {wrap-executables}: Remove.
Diffstat (limited to 'gnu/packages/education.scm')
-rw-r--r--gnu/packages/education.scm17
1 files changed, 4 insertions, 13 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 46262fd14b..fa48f900ad 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -58,6 +58,7 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
+ #:use-module (guix build-system qt)
#:use-module (guix build-system trivial)
#:use-module (srfi srfi-1))
@@ -563,15 +564,10 @@ language and very flexible regarding to new or unknown keyboard layouts.")
(sha256
(base32
"19rdk94pls75hdvx11hnfk3qpm6l28p9q45q5f04sknxagrfaznr"))))
- (build-system cmake-build-system)
+ (build-system qt-build-system)
(arguments
- `(#:modules ((guix build cmake-build-system)
- (guix build qt-utils)
- (guix build utils))
- #:imported-modules (,@%cmake-build-system-modules
- (guix build qt-utils))
- #:phases
- (modify-phases %standard-phases
+ `(#:phases
+ (modify-phases (@ (guix build qt-build-system) %standard-phases)
(add-after 'configure 'patch-makefiles
(lambda* (#:key inputs #:allow-other-keys)
(let ((qtdec (assoc-ref inputs "qtdeclarative")))
@@ -579,11 +575,6 @@ language and very flexible regarding to new or unknown keyboard layouts.")
"src/CMakeFiles/ktouch.dir/build.make")
(("/gnu/store/.*qmlcachegen")
(string-append qtdec "/bin/qmlcachegen"))))
- #t))
- (add-after 'install 'wrap-executable
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (wrap-qt-program out "ktouch"))
#t)))))
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)