summaryrefslogtreecommitdiff
path: root/gnu/packages/education.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-01-15 12:16:49 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-01-15 12:16:49 +0100
commit7cc98473241c927a726454f31e3cd98c5742a12f (patch)
treed3d602f08cfbd4d088ef916021331d5d5c604e24 /gnu/packages/education.scm
parent9e39ac415d01312facd0202a8f7225795a6a787a (diff)
downloadguix-patches-7cc98473241c927a726454f31e3cd98c5742a12f.tar
guix-patches-7cc98473241c927a726454f31e3cd98c5742a12f.tar.gz
gnu: tipp10: Adjust phases.
* gnu/packages/education.scm (tipp10)[arguments]: Return #t for "disable-new-version-check"; fix indentation.
Diffstat (limited to 'gnu/packages/education.scm')
-rw-r--r--gnu/packages/education.scm31
1 files changed, 16 insertions, 15 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 69f5a51f59..5444579059 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -161,22 +161,23 @@ of categories with some of the activities available in that category.
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'disable-new-version-check
- (lambda _
- ;; Make new version check to default to false.
- ;; TODO: Remove the checkbox from the dialog and the check itself
- (substitute* '("widget/settingspages.cpp" "widget/mainwindow.cpp")
- (("settings.value(\"check_new_version\", true)")
- "settings.value(\"check_new_version\", false)"))))
+ (lambda _
+ ;; Make new version check to default to false.
+ ;; TODO: Remove the checkbox from the dialog and the check itself
+ (substitute* '("widget/settingspages.cpp" "widget/mainwindow.cpp")
+ (("settings.value(\"check_new_version\", true)")
+ "settings.value(\"check_new_version\", false)"))
+ #t))
(replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- ;; Make program honor $PREFIX
- (substitute* "tipp10.pro"
- (("\\.path = /usr/") (string-append ".path = " out "/")))
- (substitute* "def/defines.h"
- (("\"/usr/") (string-append "\"" out "/")))
- ;; Recreate Makefile
- (zero? (system* "qmake"))))))))
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ ;; Make program honor $PREFIX
+ (substitute* "tipp10.pro"
+ (("\\.path = /usr/") (string-append ".path = " out "/")))
+ (substitute* "def/defines.h"
+ (("\"/usr/") (string-append "\"" out "/")))
+ ;; Recreate Makefile
+ (zero? (system* "qmake"))))))))
(inputs
`(("qt4" ,qt-4)
("sqlite" ,sqlite)))