summaryrefslogtreecommitdiff
path: root/gnu/packages/education.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 17:33:30 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:52:27 -0400
commit6d9044b3c895f842a241f485364544eb73579f4a (patch)
treecce4c11b7ce73675124092378fcd8f71c88a06a1 /gnu/packages/education.scm
parent19aa16d4a2f4f8b36f5bf9be3f3078e63cc1dbed (diff)
downloadguix-patches-6d9044b3c895f842a241f485364544eb73579f4a.tar
guix-patches-6d9044b3c895f842a241f485364544eb73579f4a.tar.gz
gnu: Remove childsplay.
* gnu/packages/education.scm (childsplay): Delete variable.
Diffstat (limited to 'gnu/packages/education.scm')
-rw-r--r--gnu/packages/education.scm103
1 files changed, 0 insertions, 103 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 07843142f4..3b9c01c786 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -445,109 +445,6 @@ specialized device.")
(home-page "https://bipede.fr/contrib/")
(license license:gpl3)))
-(define-public childsplay
- (package
- (name "childsplay")
- (version "3.4")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "mirror://sourceforge/schoolsplay/"
- "childsplay-" version ".tgz"))
- (sha256
- (base32
- "0z7yp2swjnbz51vn2zyfnjn40jq38l5mbh15yafmx1z3vn2z1m77"))))
- (build-system python-build-system)
- (arguments
- `(#:python ,python-2
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'unbundle-dejavu-font
- (lambda* (#:key inputs #:allow-other-keys)
- (let* ((dejavu-dir
- (string-append (assoc-ref inputs "font-dejavu")
- "/share/fonts/truetype"))
- (dejavu-font
- (string-append dejavu-dir
- "/DejaVuSansCondensed-Bold.ttf")))
- (substitute* "SPConstants.py"
- (("^(TTF(BOLD)? = ).*" _ prefix)
- (string-append prefix "'" dejavu-font "'\n")))
- (for-each (lambda (f) (delete-file f))
- (find-files "lib/SPData" "DejaVu"))
- #t)))
- (delete 'build)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (pixmaps (string-append out "/share/pixmaps"))
- (share (string-append out "/share/childsplay"))
- (doc (string-append out "/share/doc/" ,name "-",version)))
- ;; Install icon.
- (install-file "lib/SPData/themes/childsplay/logo_cp.svg" pixmaps)
- ;; Install data.
- (mkdir-p share)
- (for-each (lambda (f)
- (copy-recursively f (string-append share "/" f)))
- '("alphabet-sounds" "lib" "locale" "SPWidgets"))
- (for-each (lambda (f) (install-file f share))
- (find-files "." "\\.(py|dev|db)$"))
- ;; Install documentation.
- (mkdir-p doc)
- (copy-recursively "docs" doc)
- #t)))
- (add-after 'install 'create-executable
- (lambda* (#:key outputs inputs #:allow-other-keys)
- (let* ((python (search-input-file inputs "/bin/python"))
- (out (assoc-ref outputs "out"))
- (bin (string-append out "/bin"))
- (executable (string-append bin "/childsplay")))
- (mkdir-p bin)
- (call-with-output-file executable
- (lambda (file)
- (format file
- "~a ~a"
- python
- (string-append out "/share/childsplay/childsplay.py"))))
- (chmod executable #o555)
- #t)))
- (add-after 'install 'create-desktop-file
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (applications (string-append out "/share/applications")))
- (mkdir-p applications)
- (call-with-output-file
- (string-append applications "/childsplay.desktop")
- (lambda (file)
- (format file
- "[Desktop Entry]~@
- Name=Childsplay~@
- Comment=Suite of educational games for young children~@
- Comment[ca]=Conjunt de jocs educatius per a xiquets~@
- Comment[es]=Conjunto de juegos educativos para niños~@
- Comment[de]=Sammlung mit lehrreichen Spielen für kleine Kinder~@
- Exec=~a/bin/childsplay~@
- Terminal=false~@
- Icon=logo_cp.svg~@
- Type=Application~@
- Categories=Application;Game;Education;KidsGame;~@
- Keywords=suite;children;games;young;educational;~%"
- out)))
- #t))))))
- (inputs
- `(("font-dejavu" ,font-dejavu)
- ("pygame" ,python2-pygame)
- ("sqlalchemy" ,python2-sqlalchemy)))
- (synopsis "Suite of educational games for young children")
- (description "Childsplay is a collection of educational activities
-for young children. Childsplay can be used at home, kindergartens and
-pre-schools. Childsplay is a fun and safe way to let young children
-use the computer and at the same time teach them a little math,
-letters of the alphabet, spelling, eye-hand coordination, etc.")
- (home-page "http://www.schoolsplay.org")
- (license license:gpl3+)))
-
(define-public openboard
;; The last release builds from qtwebkit, which is planned for removal in
;; Guix, so use the latest commit of the 1.7-dev branch, which builds with