summaryrefslogtreecommitdiff
path: root/gnu/packages/education.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-11-25 13:51:17 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-11-25 13:51:17 +0200
commit6ace1ec8169665ed27f8725b8ff0c9a5cda2d456 (patch)
tree657385c4d6bff1fb17128a62a806e5159f60f2cb /gnu/packages/education.scm
parent6629aa2a83977fdff4ae7835ffa15a16050191e8 (diff)
downloadguix-patches-6ace1ec8169665ed27f8725b8ff0c9a5cda2d456.tar
guix-patches-6ace1ec8169665ed27f8725b8ff0c9a5cda2d456.tar.gz
gnu: gcompris-qt: Update to 1.0.
* gnu/packages/education.scm (gcompris-qt): Update to 1.0. [arguments]: Drop custom 'disable-failing-test phase. Set HOME to help test suite run. [inputs]: Replace python-2 with python-wrapper.
Diffstat (limited to 'gnu/packages/education.scm')
-rw-r--r--gnu/packages/education.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index cdd58ffa42..9cb916ee36 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -140,7 +140,7 @@ of categories with some of the activities available in that category.
(define-public gcompris-qt
(package
(name "gcompris-qt")
- (version "0.98")
+ (version "1.0")
(source
(origin
(method url-fetch)
@@ -148,22 +148,19 @@ of categories with some of the activities available in that category.
"https://gcompris.net/download/qt/src/gcompris-qt-"
version ".tar.xz"))
(sha256
- (base32 "1jmjykn0lpk0v6hs2flmch8v4da5bgxl891nav7szxw9l7aqnf4y"))))
+ (base32 "08dw1q0h4qz2q0ksa5pbmb9v60hr1zv9skx6z8dlq9b1i7harnds"))))
(build-system cmake-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'disable-failing-test
- (lambda _
- (substitute* "tests/core/CMakeLists.txt"
- (("DownloadManagerTest\\.cpp") "#"))
- #t))
(add-before 'check 'start-xorg-server
(lambda* (#:key inputs #:allow-other-keys)
;; The test suite requires a running X server.
(system (string-append (assoc-ref inputs "xorg-server")
"/bin/Xvfb :1 &"))
(setenv "DISPLAY" ":1")
+ ;; The test suite wants to write to /homeless-shelter
+ (setenv "HOME" (getcwd))
#t))
(add-after 'install 'wrap-executable
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -192,7 +189,7 @@ of categories with some of the activities available in that category.
("xorg-server" ,xorg-server-for-tests)))
(inputs
`(("openssl" ,openssl)
- ("python-2" ,python-2)
+ ("python" ,python-wrapper)
("qtbase" ,qtbase)
("qtdeclarative" ,qtdeclarative)
("qtgraphicaleffects" ,qtgraphicaleffects)