summaryrefslogtreecommitdiff
path: root/gnu/packages/education.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-09-10 12:45:39 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-09-16 15:01:03 +0300
commit3f19b268ea3dbd4ec266926d25f7172fbd5b9cee (patch)
tree5eda87c7cd4c1cbad8d37e419b757018dd5d8184 /gnu/packages/education.scm
parent74e7465c9b3758c1509a3e0dbe575e2014e20f0a (diff)
downloadguix-patches-3f19b268ea3dbd4ec266926d25f7172fbd5b9cee.tar
guix-patches-3f19b268ea3dbd4ec266926d25f7172fbd5b9cee.tar.gz
gnu: Add klavaro.
* gnu/packages/education.scm (klavaro): New variable.
Diffstat (limited to 'gnu/packages/education.scm')
-rw-r--r--gnu/packages/education.scm29
1 files changed, 28 insertions, 1 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 240fc4acd8..0ec1de7b75 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
-;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;;
@@ -520,3 +520,30 @@ minutes. For simpler timetables, it may take a shorter time, under
difficult timetables, it may take a longer time, a matter of hours.")
(license license:agpl3+)))
+(define-public klavaro
+ (package
+ (name "klavaro")
+ (version "3.09")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/klavaro/klavaro-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "12gml7h45b1w9s318h0d5wxw92h7pgajn2kh57j0ak9saq0yb0wr"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("cairo" ,cairo)
+ ("curl" ,curl)
+ ("gtk+" ,gtk+)
+ ("pango" ,pango)))
+ (home-page "https://klavaro.sourceforge.io/en/index.html")
+ (synopsis "Touch typing tutor")
+ (description
+ "Klavaro is a simple tutor to teach correct typing, almost independently of
+language and very flexible regarding to new or unknown keyboard layouts.")
+ (license license:gpl3+)))