summaryrefslogtreecommitdiff
path: root/gnu/packages/education.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-10-23 22:53:12 +0200
committerLudovic Courtès <ludo@gnu.org>2021-10-23 23:05:21 +0200
commit2dffe4767c64e00a2b97b71b9e2ac568ffc99595 (patch)
treef103a9611d8c02ea63d88f8f7b3c92ff8fd30201 /gnu/packages/education.scm
parente5f21c7e38fc7c61271e532f434284c94cd6fbb3 (diff)
downloadguix-patches-2dffe4767c64e00a2b97b71b9e2ac568ffc99595.tar
guix-patches-2dffe4767c64e00a2b97b71b9e2ac568ffc99595.tar.gz
gnu: Use 'search-input-file' some more.
This patch replaces occurrences of: (string-append (assoc-ref %build-inputs "…") "/…") by: (search-input-file %build-inputs "/…") * doc/guix.texi (Miscellaneous Services): Use 'search-input-file' in R Shiny example. * gnu/packages/admin.scm (screenfetch): Use 'search-input-file'. (ufetch): Likewise. (hosts): Likewise. * gnu/packages/backup.scm (dirvish): Likewise. * gnu/packages/code.scm (colormake): Likewise. * gnu/packages/compression.scm (makeself-safeextract): Likewise. * gnu/packages/debug.scm (scanmem): Likewise. * gnu/packages/education.scm (snap): Likewise. (omnitux): Likewise. * gnu/packages/emacs-xyz.scm (epipe): Likewise. * gnu/packages/games.scm (openttd-opensfx): Likewise. (openttd-openmsx): Likewise. (openrct2-title-sequences): Likewise. (openrct2-objects): Likewise. (mrrescue): Likewise. (0ad-data): Likewise. (xonotic-data): Likewise. (drascula): Likewise. (make-lure-package): Likewise. (make-queen-package): Likewise. (sky): Likewise. * gnu/packages/gnome.scm (network-manager): Likewise. * gnu/packages/gnuzilla.scm (icedove): Likewise. * gnu/packages/guile-xyz.scm (guile-shapefile): Likewise. * gnu/packages/hurd.scm (netdde): Likewise. * gnu/packages/javascript.scm (js-context-menu): Likewise. (js-commander): Likewise. (js-xmldom-sre): Likewise. * gnu/packages/kde-frameworks.scm (krunner): Likewise. * gnu/packages/kodi.scm (kodi-cli): Likewise. * gnu/packages/libreoffice.scm (hunspell-dict-pl): Likewise. * gnu/packages/linux.scm (e2fsck/static): Likewise. * gnu/packages/markup.scm (markdown): Likewise. * gnu/packages/maths.scm (hdf-java): Likewise. * gnu/packages/multiprecision.scm (libtomcrypt): Likewise. * gnu/packages/networking.scm (batctl): Likewise. * gnu/packages/python-xyz.scm (python-pymediainfo): Likewise. * gnu/packages/shells.scm (fish-foreign-env): Likewise. * gnu/packages/tex.scm (texlive-fonts-iwona): Likewise. * gnu/packages/upnp.scm (miniupnpc): Likewise. * gnu/packages/version-control.scm (git-annex-remote-rclone): Likewise. * gnu/packages/virtualization.scm (qemu): Likewise. * gnu/packages/web.scm (icedtea-web): Likewise. * gnu/packages/wm.scm (stumpish): Likewise.
Diffstat (limited to 'gnu/packages/education.scm')
-rw-r--r--gnu/packages/education.scm18
1 files changed, 8 insertions, 10 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 716f15a9db..9573a397fd 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -337,17 +337,16 @@ easy.")
;; Replace the sole minified file in the package.
(with-directory-excursion (string-append share "/src")
(delete-file "FileSaver.min.js")
- (symlink (string-append (assoc-ref %build-inputs "js-filesaver")
- "/share/javascript/FileSaver.min.js")
+ (symlink (search-input-file %build-inputs
+ "/share/javascript/FileSaver.min.js")
"FileSaver.min.js"))
;; Create a "snap" executable.
(let* ((bin (string-append out "/bin"))
(script (string-append bin "/snap"))
(snap (string-append share "/snap.html"))
- (bash (string-append (assoc-ref %build-inputs "bash")
- "/bin/sh"))
- (xdg-open (string-append (assoc-ref %build-inputs "xdg-utils")
- "/bin/xdg-open")))
+ (bash (search-input-file %build-inputs "/bin/sh"))
+ (xdg-open (search-input-file %build-inputs
+ "/bin/xdg-open")))
(mkdir-p bin)
(call-with-output-file script
(lambda (port)
@@ -589,10 +588,9 @@ letters of the alphabet, spelling, eye-hand coordination, etc.")
;; Install the launcher.
(let* ((bin (string-append out "/bin"))
(script (string-append bin "/omnitux"))
- (bash (string-append (assoc-ref %build-inputs "bash")
- "/bin/bash"))
- (python (string-append (assoc-ref %build-inputs "python")
- "/bin/python2")))
+ (bash (search-input-file %build-inputs "/bin/bash"))
+ (python (search-input-file %build-inputs
+ "/bin/python2")))
(mkdir-p bin)
(with-output-to-file script
(lambda ()