summaryrefslogtreecommitdiff
path: root/gnu/packages/education.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-10 16:35:23 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-10 16:35:23 +0300
commit1ac96992fbdee5bfff992f067c2a7f45de99a062 (patch)
treed3d7e62d0f7f6c81aede3035f266a6727675fb7b /gnu/packages/education.scm
parentedbf8272c0fb86729254a018b49f7313c2fcf55c (diff)
downloadguix-patches-1ac96992fbdee5bfff992f067c2a7f45de99a062.tar
guix-patches-1ac96992fbdee5bfff992f067c2a7f45de99a062.tar.gz
gnu: gcompris-qt: Switch to qt-build-system.
* gnu/packages/education.scm (gcompris-qt)[build-system]: Switch from cmake-build-system to qt-build-system. [arguments]: Remove custom 'wrap-executable phase.
Diffstat (limited to 'gnu/packages/education.scm')
-rw-r--r--gnu/packages/education.scm20
1 files changed, 2 insertions, 18 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index 955ab929ba..f0120c8af2 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -150,7 +150,7 @@ of categories with some of the activities available in that category.
version ".tar.xz"))
(sha256
(base32 "1bpjwrv83rhikbycpyfpf6dbqr0xfq6amgdpqfgfph6nzr3zka7h"))))
- (build-system cmake-build-system)
+ (build-system qt-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -162,23 +162,7 @@ of categories with some of the activities available in that category.
(setenv "DISPLAY" ":1")
;; The test suite wants to write to /homeless-shelter
(setenv "HOME" (getcwd))
- #t))
- (add-after 'install 'wrap-executable
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (wrap-program (string-append out "/bin/gcompris-qt")
- `("QT_PLUGIN_PATH" ":" prefix
- ,(map (lambda (label)
- (string-append (assoc-ref inputs label)
- "/lib/qt5/plugins"))
- '("qtbase" "qtdeclarative" "qtmultimedia" "qtsvg")))
- `("QML2_IMPORT_PATH" ":" prefix
- ,(map (lambda (label)
- (string-append (assoc-ref inputs label)
- "/lib/qt5/qml"))
- '("qtdeclarative" "qtgraphicaleffects"
- "qtmultimedia" "qtquickcontrols"))))
- #t))))
+ #t)))
#:configure-flags (list "-DQML_BOX2D_MODULE=disabled"
"-DBUILD_TESTING=TRUE")))
(native-inputs