summaryrefslogtreecommitdiff
path: root/gnu/packages/ebook.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2017-06-22 00:07:58 +0200
committerRoel Janssen <roel@gnu.org>2017-06-22 00:07:58 +0200
commitf70f3407ca5e62bfe5086b1b5887d93d898d658e (patch)
tree4078bd28b7e85771fe649531f14b89b979e59685 /gnu/packages/ebook.scm
parentbb19b2ebf3a6661e1c8eb22c70bc7759fe20e0db (diff)
downloadguix-patches-f70f3407ca5e62bfe5086b1b5887d93d898d658e.tar
guix-patches-f70f3407ca5e62bfe5086b1b5887d93d898d658e.tar.gz
gnu: Update calibre to 3.0.0.
* gnu/local.mk: Remove patch. * gnu/packages/ebook.scm (calibre): Update to 3.0.0. * gnu/packages/patches/calibre-dont-load-remote-icons.patch: Remove file.
Diffstat (limited to 'gnu/packages/ebook.scm')
-rw-r--r--gnu/packages/ebook.scm14
1 files changed, 10 insertions, 4 deletions
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 1d64e9b69f..bbb127a7d9 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016, 2017 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2017 Brendan Tildesley <brendan.tildesley@openmailbox.org>
+;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -65,7 +66,7 @@
(define-public calibre
(package
(name "calibre")
- (version "2.85.1")
+ (version "3.0.0")
(source
(origin
(method url-fetch)
@@ -74,7 +75,7 @@
version ".tar.xz"))
(sha256
(base32
- "1g8s0kp1gj05yysfgqpp2lgrxvzc0fsny1hwzx5jh9hvqn0b53cc"))
+ "1zhk7bvgr973dd18x4wp48kzai29qqqi5qcy72sxc4wcbk2sbnkw"))
;; Remove non-free or doubtful code, see
;; https://lists.gnu.org/archive/html/guix-devel/2015-02/msg00478.html
(modules '((guix build utils)))
@@ -84,13 +85,11 @@
(delete-file-recursively "src/unrar")
(delete-file "src/odf/thumbnail.py")
(delete-file-recursively "resources/fonts/liberation")
- (delete-file-recursively "src/chardet")
(substitute* (find-files "." "\\.py")
(("calibre\\.ebooks\\.markdown") "markdown"))
#t))
(patches (search-patches "calibre-drop-unrar.patch"
"calibre-use-packaged-feedparser.patch"
- "calibre-dont-load-remote-icons.patch"
"calibre-no-updates-dialog.patch"))))
(build-system python-build-system)
(native-inputs
@@ -132,6 +131,7 @@
("python2-pygments" ,python2-pygments)
("python2-pyqt" ,python2-pyqt)
("python2-sip" ,python2-sip)
+ ("python2-regex" ,python2-regex)
("sqlite" ,sqlite)))
(arguments
`(#:python ,python-2
@@ -148,6 +148,12 @@
;; We can't use the uninstaller in Guix. Don't build it.
(("self\\.create_uninstaller()") ""))
#t))
+ (add-after 'unpack 'dont-load-remote-icons
+ (lambda _
+ (substitute* "setup/plugins_mirror.py"
+ (("href=\"//calibre-ebook.com/favicon.ico\"")
+ "href=\"favicon.ico\""))
+ #t))
(add-before 'build 'configure
(lambda* (#:key inputs #:allow-other-keys)
(let ((podofo (assoc-ref inputs "podofo"))